aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:35 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:35 +0000
commit68358b9d2847f60b1bfeb0df1188adb03ab202be (patch)
tree1d34071a446f3ce5d6cf16673e7a4b55d41eba0a /target
parentfda357882da312f41889e5a582a04ac327e86e71 (diff)
downloadupstream-68358b9d2847f60b1bfeb0df1188adb03ab202be.tar.gz
upstream-68358b9d2847f60b1bfeb0df1188adb03ab202be.tar.bz2
upstream-68358b9d2847f60b1bfeb0df1188adb03ab202be.zip
ar71xx: add support for tp-link wr740n v5.0 (EU)
TP-Link ships wr740n v5.0 to Romania (so probably everywhere except China) with 4 MB flash and 32 MB memory (confirmed by their local support). This patch adds support for the v5.0 clone of v4, i just tested it on my own v5.0 router and it works. Signed-off-by: Daniel Petre <daniel.petre@posteo.net> Backport of r46115 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48832 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 43366971bc..1fe88d5443 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -501,6 +501,14 @@ define Device/tl-wr740n-v4
CONSOLE := ttyATH0,115200
endef
+define Device/tl-wr740n-v5
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR741ND-v4
+ DEVICE_PROFILE := TLWR740
+ TPLINK_HWID := 0x07400005
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/tl-wr741nd-v1
$(Device/tplink-4m)
BOARDNAME := TL-WR741ND
@@ -530,7 +538,7 @@ define Device/tl-wr743nd-v2
TPLINK_HWID := 0x07430002
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
define Device/tl-wr841n-v8
$(Device/tplink-4mlzma)