aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-28 13:49:17 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-28 13:49:17 +0000
commit5cd358eb5d66470c32c4e0c282fc729420709648 (patch)
treed3ca8e2b2631fd506f259eef2bf4aaf7313da751 /target
parent7fdea88dc45a31e8b44dcd3f3f7252602bd8d02a (diff)
downloadupstream-5cd358eb5d66470c32c4e0c282fc729420709648.tar.gz
upstream-5cd358eb5d66470c32c4e0c282fc729420709648.tar.bz2
upstream-5cd358eb5d66470c32c4e0c282fc729420709648.zip
ar71xx: override mtd partitions for the TEW-632BRP family
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18578 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 04629ffd54..6f913f5ec8 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -77,11 +77,12 @@ define Image/Build/WRT400N
fi; fi
endef
+cameo_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,896k(kernel),2880k(rootfs),64k(art)ro,3776k@0x30000(firmware)
define Image/Build/Cameo
- $(call PatchKernelLzma,$(2),$(3))
- if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 851968 ]; then \
+ $(call PatchKernelLzma,$(2),$(3) $(cameo_mtdlayout))
+ if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
- else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 3014656 ]; then \
+ else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2949120 ]; then \
echo "Warning: $(KDIR)/root.$(1) is too big"; \
else \
mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
@@ -89,8 +90,8 @@ define Image/Build/Cameo
-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
- dd if=$(KDIR)/vmlinux-$(2).uImage bs=832k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=2944k conv=sync; \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=2880k conv=sync; \
echo -n $(4); \
) > $(call imgname,$(1),$(2)).uni; \
fi; fi