aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:26 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:26 +0000
commit59c9cec78711f0795ee6cd2a79fc8d58f31a432f (patch)
tree7b949ee6b8d821dd6bf47bf870ad8ce4d26bd6da /target
parent2082201b9c59c0509e1f75f89df7c4e6d1acdb94 (diff)
downloadupstream-59c9cec78711f0795ee6cd2a79fc8d58f31a432f.tar.gz
upstream-59c9cec78711f0795ee6cd2a79fc8d58f31a432f.tar.bz2
upstream-59c9cec78711f0795ee6cd2a79fc8d58f31a432f.zip
brcm63xx: add a dummy image recipe for boards missing proper images
Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 3c68cdbb11..a2130f3bd2 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -106,6 +106,11 @@ define Image/Build/ChkDTB
-k $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin -b $(5) -r $(6)
endef
+define Image/Build/Dummy
+ # for boards without a flashable image yet
+ true
+endef
+
define Build/Clean
$(MAKE) -C lzma-loader clean
endef
@@ -295,7 +300,7 @@ $(eval $(call ImageDTB,CFEDTB,HG556a_C,HG556a_C,hg556a-c,HW556,6358,--rsa-signat
# Inventel Livebox 1
$(eval $(call ImageDTB,RedBootDTB,Livebox,livebox,livebox-blue-5g))
# Netgear CVG834G
-$(eval $(call ImageDTB,HCSDTB,CVG834G,,cvg834g,a020,0001,0022,vmlinux-cvg834g))
+$(eval $(call ImageDTB,Dummy,CVG834G,cvg834g,cvg834g,a020,0001,0022,vmlinux-cvg834g))
# Netgear DG834GT/PN
$(eval $(call ImageDTB,CFEDTB,DG834GTPN,DG834GT_PN,dg834gtpn,96348GW-10,6348))
# Netgear DGND3700 v1 / DGND3800B