aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:30:18 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:30:18 +0000
commit2830947555b70b6dd5a2da8f5d7d3db6b4903f52 (patch)
tree0df7d41a556163993e1d67629d5adeab2dcb9970 /target
parent25eee465a964fd5f2b9d01d5baec7105b23a2a03 (diff)
downloadupstream-2830947555b70b6dd5a2da8f5d7d3db6b4903f52.tar.gz
upstream-2830947555b70b6dd5a2da8f5d7d3db6b4903f52.tar.bz2
upstream-2830947555b70b6dd5a2da8f5d7d3db6b4903f52.zip
malta: remove le64/be64 references
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47233 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/malta/be64/config-default30
-rw-r--r--target/linux/malta/be64/target.mk10
-rw-r--r--target/linux/malta/le64/config-default30
-rw-r--r--target/linux/malta/le64/target.mk10
5 files changed, 1 insertions, 81 deletions
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 06cb68aee4..b3fff52212 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
BOARD:=malta
BOARDNAME:=MIPS Malta CoreLV board (qemu)
-SUBTARGETS:=le be #le64 be64
+SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
diff --git a/target/linux/malta/be64/config-default b/target/linux/malta/be64/config-default
deleted file mode 100644
index b424c3ed3b..0000000000
--- a/target/linux/malta/be64/config-default
+++ /dev/null
@@ -1,30 +0,0 @@
-# CONFIG_32BIT is not set
-CONFIG_64BIT=y
-CONFIG_ARCH_DMA_ADDR_T_64BIT=y
-CONFIG_ARCH_WANT_COMPAT_IPC_PARSE_VERSION=y
-CONFIG_ARCH_WANT_OLD_COMPAT_IPC=y
-CONFIG_BINFMT_ELF32=y
-CONFIG_BLOCK_COMPAT=y
-CONFIG_COMPAT=y
-CONFIG_COMPAT_NETLINK_MESSAGES=y
-CONFIG_CPU_BIG_ENDIAN=y
-# CONFIG_CPU_LITTLE_ENDIAN is not set
-# CONFIG_CPU_MIPS32_R1 is not set
-# CONFIG_CPU_MIPS32_R2 is not set
-CONFIG_CPU_MIPS64=y
-CONFIG_CPU_MIPS64_R1=y
-# CONFIG_CPU_MIPS64_R2 is not set
-CONFIG_CPU_MIPSR1=y
-CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
-CONFIG_CPU_SUPPORTS_64BIT_KERNEL=y
-CONFIG_CPU_SUPPORTS_HUGEPAGES=y
-CONFIG_HAVE_64BIT_ALIGNED_ACCESS=y
-CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE=y
-# CONFIG_HUGETLBFS is not set
-CONFIG_MIPS32_COMPAT=y
-CONFIG_MIPS32_N32=y
-CONFIG_MIPS32_O32=y
-CONFIG_MODULES_USE_ELF_RELA=y
-CONFIG_PHYS_ADDR_T_64BIT=y
-CONFIG_SYSVIPC_COMPAT=y
-CONFIG_SYS_SUPPORTS_HUGETLBFS=y
diff --git a/target/linux/malta/be64/target.mk b/target/linux/malta/be64/target.mk
deleted file mode 100644
index dad3a1c6c5..0000000000
--- a/target/linux/malta/be64/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-ARCH:=mips64
-ARCH_PACKAGES:=malta_mips64
-SUBTARGET:=be64
-BOARDNAME:=Big Endian (64-bits)
-FEATURES:=ramdisk
-
-define Target/Description
- Build BE firmware images for MIPS Malta CoreLV board running in
- big-endian and 64-bits mode
-endef
diff --git a/target/linux/malta/le64/config-default b/target/linux/malta/le64/config-default
deleted file mode 100644
index 8b5731e65a..0000000000
--- a/target/linux/malta/le64/config-default
+++ /dev/null
@@ -1,30 +0,0 @@
-# CONFIG_32BIT is not set
-CONFIG_64BIT=y
-CONFIG_ARCH_DMA_ADDR_T_64BIT=y
-CONFIG_ARCH_WANT_COMPAT_IPC_PARSE_VERSION=y
-CONFIG_ARCH_WANT_OLD_COMPAT_IPC=y
-CONFIG_BINFMT_ELF32=y
-CONFIG_BLOCK_COMPAT=y
-CONFIG_COMPAT=y
-CONFIG_COMPAT_NETLINK_MESSAGES=y
-# CONFIG_CPU_BIG_ENDIAN is not set
-CONFIG_CPU_LITTLE_ENDIAN=y
-# CONFIG_CPU_MIPS32_R1 is not set
-# CONFIG_CPU_MIPS32_R2 is not set
-CONFIG_CPU_MIPS64=y
-CONFIG_CPU_MIPS64_R1=y
-# CONFIG_CPU_MIPS64_R2 is not set
-CONFIG_CPU_MIPSR1=y
-CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
-CONFIG_CPU_SUPPORTS_64BIT_KERNEL=y
-CONFIG_CPU_SUPPORTS_HUGEPAGES=y
-CONFIG_HAVE_64BIT_ALIGNED_ACCESS=y
-CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE=y
-# CONFIG_HUGETLBFS is not set
-CONFIG_MIPS32_COMPAT=y
-CONFIG_MIPS32_N32=y
-CONFIG_MIPS32_O32=y
-CONFIG_MODULES_USE_ELF_RELA=y
-CONFIG_PHYS_ADDR_T_64BIT=y
-CONFIG_SYSVIPC_COMPAT=y
-CONFIG_SYS_SUPPORTS_HUGETLBFS=y
diff --git a/target/linux/malta/le64/target.mk b/target/linux/malta/le64/target.mk
deleted file mode 100644
index 26b53c12bd..0000000000
--- a/target/linux/malta/le64/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-ARCH:=mips64el
-ARCH_PACKAGES:=malta_mipsel64
-SUBTARGET:=le64
-BOARDNAME:=Little Endian (64-bits)
-FEATURES:=ramdisk
-
-define Target/Description
- Build LE firmware images for MIPS Malta CoreLV board running in
- little-endian and 64-bits mode
-endef