aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-09-21 11:47:44 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-09-21 11:47:44 +0000
commit1d3825973dc136d8ef975cab5ff5343f4b45654b (patch)
tree9963ed1c82ce0241e143edfaf28a91467aef56f5 /target
parent821f14fb0a49514123ffc2a87dfbba1644e350f0 (diff)
downloadupstream-1d3825973dc136d8ef975cab5ff5343f4b45654b.tar.gz
upstream-1d3825973dc136d8ef975cab5ff5343f4b45654b.tar.bz2
upstream-1d3825973dc136d8ef975cab5ff5343f4b45654b.zip
ar71xx: create image for the TP-Link TL-WR743ND v1
Same hardware as WR741ND but with PoE support. Signed-off-by: Paul Fertser <fercerpav@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28271 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile5
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index f5a7a24a93..c770d49151 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -84,6 +84,17 @@ endef
$(eval $(call Profile,TLWR740NV3))
+define Profile/TLWR743NDV1
+ NAME:=TP-LINK TL-WR743ND v1
+ PACKAGES:=
+endef
+
+define Profile/TLWR743NDV1/Description
+ Package set optimized for the TP-LINK TL-WR743ND v1.
+endef
+
+$(eval $(call Profile,TLWR743NDV1))
+
define Profile/TLWR841NV15
NAME:=TP-LINK TL-WR841N v1.5
PACKAGES:=
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d808a1d8aa..e4163b33e5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -596,6 +596,10 @@ define Image/Build/Profile/TLWR740NV3
$(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v3,$(tlwe740nv3_cmdline),TL-WR740Nv3)
endef
+define Image/Build/Profile/TLWR743NDV1
+ $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr743nd-v1,$(tlwe741ndv1_cmdline),TL-WR743NDv1)
+endef
+
tlwr841nv15_cmdline=board=TL-WR841N-v1.5 console=ttyS0,115200
define Image/Build/Profile/TLWR841NV15
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,$(tlwr841nv15_cmdline),TL-WR841Nv1.5)
@@ -709,6 +713,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR741NDV1,$(1))
$(call Image/Build/Profile/TLWR740NV1,$(1))
$(call Image/Build/Profile/TLWR740NV3,$(1))
+ $(call Image/Build/Profile/TLWR743NDV1,$(1))
$(call Image/Build/Profile/TLWR841NV15,$(1))
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))