aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-28 09:28:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-28 09:28:25 +0000
commit1c396a22fd09cc9752a339e8420c307816f8c6c6 (patch)
tree30df8d495d259d3c29bdf49bcd341ce4e82dff23 /target
parent050ea33a0b437db2e22a70fe7933662200ae6975 (diff)
downloadupstream-1c396a22fd09cc9752a339e8420c307816f8c6c6.tar.gz
upstream-1c396a22fd09cc9752a339e8420c307816f8c6c6.tar.bz2
upstream-1c396a22fd09cc9752a339e8420c307816f8c6c6.zip
ar71xx: create images for the WNDR3700, which can be flashed via the factory web interface
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18571 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4c88a85e64..04629ffd54 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -241,6 +241,10 @@ define Image/Build/WNDR3700
dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1M conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k; \
) > $(call imgname,$(1),$(2))-sysupgrade.bin
+ $(STAGING_DIR_HOST)/bin/mkdniimg \
+ -B WNDR3700 -v OpenWrt.$(REVISION) \
+ -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+ -o $(call imgname,$(1),$(2))-factory.bin
endef
define Image/Build/Template/Compex