aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-07-20 17:31:05 +0000
committerJohn Crispin <blogic@openwrt.org>2014-07-20 17:31:05 +0000
commitfefd51407f9623fc7b235abe6a7856a9ddcda358 (patch)
tree04fc1096021610f0e0f323ed4b9f2d2e9dd127b6 /target
parent6cd7d2f54843253d1c1bc69b9d73abe17b7f4e89 (diff)
downloadupstream-fefd51407f9623fc7b235abe6a7856a9ddcda358.tar.gz
upstream-fefd51407f9623fc7b235abe6a7856a9ddcda358.tar.bz2
upstream-fefd51407f9623fc7b235abe6a7856a9ddcda358.zip
ar71xx: create profile and build image for the OpenMesh OM5P board
Signed-off-by: Marek Lindner <marek@open-mesh.com> [sven@open-mesh.com: Rebased] Signed-off-by: Sven Eckelmann <sven@open-mesh.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41775 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile3
2 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
index 2f33d83c3e..c8846de638 100644
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
@@ -16,6 +16,17 @@ endef
$(eval $(call Profile,OM2P))
+define Profile/OM5P
+ NAME:=OpenMesh OM5P
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OM5P/Description
+ Package set optimized for the OpenMesh OM5P.
+endef
+
+$(eval $(call Profile,OM5P))
+
define Profile/MR600
NAME:=OpenMesh MR600
PACKAGES:=kmod-ath9k om-watchdog
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a7fd5687ac..4350a2d2d3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1115,6 +1115,7 @@ $(eval $(call SingleProfile,Netgear,64kraw,WNDRMAC,wndrmac,WNDR3700,ttyS0,115200
$(eval $(call SingleProfile,Netgear,64kraw,WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),0x33373031,WNDRMACv2,"",-H 29763654+16+128))
$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
$(eval $(call SingleProfile,PB4X,128k,ALL0305,all0305,ALL0305,ttyS0,115200))
@@ -1242,7 +1243,7 @@ $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
$(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
$(eval $(call MultiProfile,ARCHERC7, ARCHERC7V1 ARCHERC7V2))
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
-$(eval $(call MultiProfile,OPENMESH,OM2P MR600))
+$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600))
$(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
$(eval $(call MultiProfile,TLMR11U,TLMR11UV1 TLMR11UV2))
$(eval $(call MultiProfile,TLMR3040,TLMR3040V1 TLMR3040V2))