aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-03-18 15:57:18 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-03-18 15:57:18 +0000
commit8b4b882158ca8d522481f71f39835da12881c6a5 (patch)
tree71f9b95b71bfc4cfaa2bb0c858327a2655d4c2ba /target
parent81f7f38aca9d5cef305353e72491e59c4aaf35c6 (diff)
downloadupstream-8b4b882158ca8d522481f71f39835da12881c6a5.tar.gz
upstream-8b4b882158ca8d522481f71f39835da12881c6a5.tar.bz2
upstream-8b4b882158ca8d522481f71f39835da12881c6a5.zip
Add FEATURE ramdisk to be able to select the use of INITRAMFS for a sub-target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14939 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/Config.in3
-rw-r--r--target/linux/ps3/petitboot/target.mk4
2 files changed, 5 insertions, 2 deletions
diff --git a/target/Config.in b/target/Config.in
index 31f7a50b39..6506312b37 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -29,6 +29,9 @@ config USB_SUPPORT
config BIG_ENDIAN
bool
+config USES_INITRAMFS
+ bool
+
config USES_SQUASHFS
bool
diff --git a/target/linux/ps3/petitboot/target.mk b/target/linux/ps3/petitboot/target.mk
index a3d84dde03..4b53f57b6b 100644
--- a/target/linux/ps3/petitboot/target.mk
+++ b/target/linux/ps3/petitboot/target.mk
@@ -1,7 +1,7 @@
BOARDNAME:=Petitboot
-FEATURES:=fpu
+FEATURES:=fpu ramdisk
-DEFAULT_PACKAGES+= dnsmasq
+DEFAULT_PACKAGES+= dnsmasq petitboot
define Target/Description
Build Petitboot bootloader