aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-17 11:01:24 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-17 11:01:24 +0000
commit77841ac875ffca210c2429a5e63c9c396bd38044 (patch)
tree8b8a8503506a846ef274942d6a148644624ecc5b /target
parentbee00f907828e2fc47ed5a8ecc1069473ec223fe (diff)
downloadupstream-77841ac875ffca210c2429a5e63c9c396bd38044.tar.gz
upstream-77841ac875ffca210c2429a5e63c9c396bd38044.tar.bz2
upstream-77841ac875ffca210c2429a5e63c9c396bd38044.zip
sdk: predefine kernel version magic
Kernel modules which are built using the SDK do not have access to the .vermagic file in the Linux build dir, therefore the generated .ipk metadata depends on kernel versions like '3.10.49-1-unknown' which are not satisfiable by the kernel meta package in the image. Fix this problem by substituting 'unknown' with the current version magic in include/kernel.mk when packing the SDK. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42590 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42592 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/sdk/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index a2cd3a5ab0..1c696d5ac4 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -108,6 +108,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
cat $(TOPDIR)/feeds.conf.default \
>> $(SDK_BUILD_DIR)/feeds.conf.default
$(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(SDK_BUILD_DIR)/include/version.mk
+ $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(SDK_BUILD_DIR)/include/kernel.mk
find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf