aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-02-19 11:52:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-02-19 11:52:33 +0000
commit61eb5058896d6f2107a81446c30a8929e6933da6 (patch)
tree2f4b8bb019b3b86ce3fbf248f96285ca459ffdc3 /target
parent7419011330d63dc7af56dbc68215e4d7b2108796 (diff)
downloadupstream-61eb5058896d6f2107a81446c30a8929e6933da6.tar.gz
upstream-61eb5058896d6f2107a81446c30a8929e6933da6.tar.bz2
upstream-61eb5058896d6f2107a81446c30a8929e6933da6.zip
ar71xx: create firmware images for the TL-WR941ND v4 board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19749 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile5
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk11
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f5bafdb90d..c7d4fc147f 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -488,6 +488,10 @@ define Image/Build/Profile/TLWR941NDV2
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
endef
+define Image/Build/Profile/TLWR941NDV4
+ $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr941nd-v4,board=TL-WR741ND,TL-WR941NDv4)
+endef
+
define Image/Build/Profile/TLWR1043NDV1
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr1043nd-v1,board=TL-WR1043ND,TL-WR1043NDv1)
endef
@@ -530,6 +534,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))
$(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/TLWR941NDV4,$(1))
$(call Image/Build/Profile/TLWR1043NDV1,$(1))
$(call Image/Build/Profile/UBNT,$(1))
$(call Image/Build/Profile/WP543,$(1))
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
index 09fbcc9e7e..ffb3b9e06d 100644
--- a/target/linux/ar71xx/profiles/tp-link.mk
+++ b/target/linux/ar71xx/profiles/tp-link.mk
@@ -60,6 +60,17 @@ endef
$(eval $(call Profile,TLWR941NDV2))
+define Profile/TLWR941NDV4
+ NAME:=TP-LINK TL-WR941ND v4
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV4/Description
+ Package set optimized for the TP-LINK TL-WR941ND v4.
+endef
+
+$(eval $(call Profile,TLWR941NDV4))
+
define Profile/TLWR1043NDV1
NAME:=TP-LINK TL-WR1043ND v1
PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2