aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-23 12:42:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-23 12:42:16 +0000
commit605dc51087a3408d538bfac9f7659d974ea74cdf (patch)
treec70eaa1bf0a08ce8dff53b187f6577427b3726c5 /target
parent09fe1c8d03de817a4af829dc149a92dfbbb67068 (diff)
downloadupstream-605dc51087a3408d538bfac9f7659d974ea74cdf.tar.gz
upstream-605dc51087a3408d538bfac9f7659d974ea74cdf.tar.bz2
upstream-605dc51087a3408d538bfac9f7659d974ea74cdf.zip
ar71xx: add support for TL-WR740N v1
Same as TL-WR741ND but with different hardware ID and without detachable antenna. Signed-off-by: Paul Fertser <fercerpav@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24811 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile5
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index a36e1756f6..df3873c034 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -49,6 +49,17 @@ endef
$(eval $(call Profile,TLWR741NDV1))
+define Profile/TLWR740NV1
+ NAME:=TP-LINK TL-WR740N v1
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR740NV1/Description
+ Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
define Profile/TLWR841NV15
NAME:=TP-LINK TL-WR841N v1.5
PACKAGES:=kmod-ath9k wpad-mini
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f6dc3b01fd..f1a9362184 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -590,6 +590,10 @@ define Image/Build/Profile/TLWR741NDV1
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
endef
+define Image/Build/Profile/TLWR740NV1
+ $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr740n-v1,board=TL-WR741ND,TL-WR740Nv1)
+endef
+
define Image/Build/Profile/TLWR841NV15
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,board=TL-WR841N-v1.5,TL-WR841Nv1.5)
endef
@@ -677,6 +681,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLMR3420V1,$(1))
$(call Image/Build/Profile/TLWA901NDV1,$(1))
$(call Image/Build/Profile/TLWR741NDV1,$(1))
+ $(call Image/Build/Profile/TLWR740NV1,$(1))
$(call Image/Build/Profile/TLWR841NV15,$(1))
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))