aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-25 07:44:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-25 07:44:45 +0000
commite55bf8c335b197ef20ad13227342976c39f12ed2 (patch)
treea7e897c9b2de5d5d9f680750ca5a8f67382cba6b /target
parent47e45167d90f0c1cc6bf8241f5ed2116de2f3b24 (diff)
downloadupstream-e55bf8c335b197ef20ad13227342976c39f12ed2.tar.gz
upstream-e55bf8c335b197ef20ad13227342976c39f12ed2.tar.bz2
upstream-e55bf8c335b197ef20ad13227342976c39f12ed2.zip
ar71xx: TL-MR3020: fix board detection, fix missing mandatory package and modify LED behaviour
This patch fixes the board detection of the TL-MR3020. The LED behaviour has also been modified: * The WPS LED is the diag LED now. * A netdev trigger for the LAN LED has been added. The profile of the TL-MR3020 has been updated because the needed package "kmod-ledtrig-usbdev" was missing which resulted in a non-working usbdev trigger for the 3G/USB LED. [juhosg: the board name changes has been removed, and the kernel files has been changed instead.] Signed-off-by: Christian Cier-Zniewski <c.cier@gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/diag.sh4
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/leds1
-rw-r--r--target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tl-mr3020.c2
-rw-r--r--target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tl-mr3020.c2
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk2
5 files changed, 7 insertions, 4 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 76f263b64b..f30ad05223 100755
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -97,7 +97,9 @@ get_status_led() {
tew-632brp)
status_led="tew-632brp:green:status"
;;
- tl-mr3020 | \
+ tl-mr3020)
+ status_led="tp-link:green:wps"
+ ;;
tl-mr3220 | \
tl-mr3420 | \
tl-wa901nd | \
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/leds b/target/linux/ar71xx/base-files/etc/uci-defaults/leds
index 45be6bd0f1..f65af4a412 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/leds
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/leds
@@ -146,6 +146,7 @@ om2p)
tl-mr3020)
set_led_usbdev "usb" "USB" "tp-link:green:3g" "1-1"
set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
+ set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
;;
tl-mr3220 | \
diff --git a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tl-mr3020.c b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tl-mr3020.c
index 21ec3e0f77..cccb4d4b03 100644
--- a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tl-mr3020.c
+++ b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tl-mr3020.c
@@ -118,5 +118,5 @@ static void __init tl_mr3020_setup(void)
ar9xxx_add_device_wmac(ee, mac);
}
-MIPS_MACHINE(AR71XX_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020 v1",
+MIPS_MACHINE(AR71XX_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020",
tl_mr3020_setup);
diff --git a/target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tl-mr3020.c b/target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tl-mr3020.c
index 35be0f7ad4..9732d5cd56 100644
--- a/target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tl-mr3020.c
+++ b/target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tl-mr3020.c
@@ -117,5 +117,5 @@ static void __init tl_mr3020_setup(void)
ath79_register_wmac(ee, mac);
}
-MIPS_MACHINE(ATH79_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020 v1",
+MIPS_MACHINE(ATH79_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020",
tl_mr3020_setup);
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 8f1314ad50..e927696082 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -7,7 +7,7 @@
define Profile/TLMR3020
NAME:=TP-LINK TL-MR3020
- PACKAGES:=kmod-usb-core kmod-usb2
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/TLMR3020/Description