aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-04-13 13:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-04-13 13:38:45 +0000
commitd275344c3eb5ac5c3308d9749ae3df5552589292 (patch)
tree904c5bef00668d8ebb798a5776572ba32c5c8bca /target
parent903019e50d2b2fcff274447f71aa3fec91a0ea0d (diff)
downloadupstream-d275344c3eb5ac5c3308d9749ae3df5552589292.tar.gz
upstream-d275344c3eb5ac5c3308d9749ae3df5552589292.tar.bz2
upstream-d275344c3eb5ac5c3308d9749ae3df5552589292.zip
kernel: fix arm compressed images build on mac os x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31274 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-3.2/350-arm_compressed_size.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/350-arm_compressed_size.patch b/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
new file mode 100644
index 0000000000..05d6618e91
--- /dev/null
+++ b/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/boot/compressed/Makefile
++++ b/arch/arm/boot/compressed/Makefile
+@@ -127,7 +127,7 @@ ccflags-y := -fpic -fno-builtin -I$(obj)
+ asflags-y := -Wa,-march=all
+
+ # Supply kernel BSS size to the decompressor via a linker symbol.
+-KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
++KBSS_SZ = $(shell $(CROSS_COMPILE)size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
+ LDFLAGS_vmlinux = --defsym _kernel_bss_size=$(KBSS_SZ)
+ # Supply ZRELADDR to the decompressor via a linker symbol.
+ ifneq ($(CONFIG_AUTO_ZRELADDR),y)