aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-01-06 12:22:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-01-06 12:22:29 +0000
commitb618c4a0585329042aa15ba2b9eee917f0686a74 (patch)
tree7d283aae89a2e373680a5c0c662b01c71a84dcd0 /target
parente3ee5c02e6a2e7e0c137701c4b32bf2fdfd1b9df (diff)
downloadupstream-b618c4a0585329042aa15ba2b9eee917f0686a74.tar.gz
upstream-b618c4a0585329042aa15ba2b9eee917f0686a74.tar.bz2
upstream-b618c4a0585329042aa15ba2b9eee917f0686a74.zip
Added support for ATM (needed by ueagle-atm), USB ATM, and VISOR USB serial controller to 2.6 and 2.4 x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2845 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/Config.in8
-rw-r--r--target/linux/linux-2.4/config/x862
-rw-r--r--target/linux/linux-2.6/Makefile4
-rw-r--r--target/linux/linux-2.6/config/brcm33
-rw-r--r--target/linux/linux-2.6/config/x8613
5 files changed, 56 insertions, 4 deletions
diff --git a/target/linux/Config.in b/target/linux/Config.in
index a0fc80413a..e56b2c82bd 100644
--- a/target/linux/Config.in
+++ b/target/linux/Config.in
@@ -126,6 +126,7 @@ config BR2_PACKAGE_KMOD_ATM
prompt "kmod-atm.......................... ATM support"
tristate
default y if BR2_LINUX_2_4_AR7
+ default m if BR2_LINUX_2_6_BRCM
help
ATM support
@@ -163,6 +164,7 @@ config BR2_PACKAGE_KMOD_PPPOATM
prompt "kmod-pppoatm.................... PPPoA (PPP over ATM) kernel support"
tristate
default y if BR2_LINUX_2_4_AR7
+ default m if BR2_LINUX_2_6_BRCM
default m
depends BR2_PACKAGE_KMOD_PPP
select BR2_PACKAGE_KMOD_ATM
@@ -762,6 +764,12 @@ config BR2_PACKAGE_KMOD_USB_STORAGE
default m
depends BR2_PACKAGE_KMOD_USB_CONTROLLER
+config BR2_PACKAGE_KMOD_USB_ATM
+ prompt "kmod-usb-atm...................... Support for USB ATM devices"
+ tristate
+ default m
+ depends BR2_PACKAGE_KMOD_USB_CONTROLLER
+
comment "Misc. devices support"
config BR2_PACKAGE_KMOD_AX25
diff --git a/target/linux/linux-2.4/config/x86 b/target/linux/linux-2.4/config/x86
index c378a24936..6edf6cc4b6 100644
--- a/target/linux/linux-2.4/config/x86
+++ b/target/linux/linux-2.4/config/x86
@@ -1333,7 +1333,7 @@ CONFIG_USB_SERIAL_BELKIN=m
# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
# CONFIG_USB_SERIAL_EMPEG is not set
CONFIG_USB_SERIAL_FTDI_SIO=m
-# CONFIG_USB_SERIAL_VISOR is not set
+CONFIG_USB_SERIAL_VISOR=m
# CONFIG_USB_SERIAL_IPAQ is not set
# CONFIG_USB_SERIAL_IR is not set
# CONFIG_USB_SERIAL_EDGEPORT is not set
diff --git a/target/linux/linux-2.6/Makefile b/target/linux/linux-2.6/Makefile
index 423be9f6e9..d64d7cca06 100644
--- a/target/linux/linux-2.6/Makefile
+++ b/target/linux/linux-2.6/Makefile
@@ -366,6 +366,10 @@ $(eval $(call KMOD_template,USB_SERIAL_PL2303,usb-serial-pl2303,\
$(MODULES_DIR)/kernel/drivers/usb/serial/pl2303.ko \
,CONFIG_USB_SERIAL_PL2303,kmod-usb-serial,61,pl2303))
+$(eval $(call KMOD_template,USB_SERIAL_VISOR,usb-serial-visor,\
+ $(MODULES_DIR)/kernel/drivers/usb/serial/visor.o \
+,CONFIG_USB_SERIAL_VISOR,kmod-usb-serial,61,visor))
+
$(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
$(MODULES_DIR)/kernel/drivers/scsi/scsi_mod.ko \
$(MODULES_DIR)/kernel/drivers/scsi/sd_mod.ko \
diff --git a/target/linux/linux-2.6/config/brcm b/target/linux/linux-2.6/config/brcm
index 0e658df1ad..ce357752ef 100644
--- a/target/linux/linux-2.6/config/brcm
+++ b/target/linux/linux-2.6/config/brcm
@@ -459,7 +459,13 @@ CONFIG_BRIDGE_EBT_ULOG=m
# SCTP Configuration (EXPERIMENTAL)
#
# CONFIG_IP_SCTP is not set
-# CONFIG_ATM is not set
+CONFIG_ATM=m
+CONFIG_ATM_CLIP=m
+CONFIG_ATM_CLIP_NO_ICMP=y
+CONFIG_ATM_LANE=m
+CONFIG_ATM_MPOA=m
+CONFIG_ATM_BR2684=m
+CONFIG_ATM_BR2684_IPFILTER=y
CONFIG_BRIDGE=y
CONFIG_VLAN_8021Q=y
# CONFIG_DECNET is not set
@@ -486,6 +492,7 @@ CONFIG_NET_SCH_CLK_JIFFIES=y
CONFIG_NET_SCH_CBQ=m
CONFIG_NET_SCH_HTB=m
CONFIG_NET_SCH_HFSC=m
+CONFIG_NET_SCH_ATM=m
CONFIG_NET_SCH_PRIO=m
CONFIG_NET_SCH_RED=m
CONFIG_NET_SCH_SFQ=m
@@ -940,6 +947,23 @@ CONFIG_NET_WIRELESS=y
# Wan interfaces
#
# CONFIG_WAN is not set
+
+#
+# ATM drivers
+#
+CONFIG_ATM_DUMMY=m
+CONFIG_ATM_TCP=m
+# CONFIG_ATM_LANAI is not set
+# CONFIG_ATM_ENI is not set
+# CONFIG_ATM_FIRESTREAM is not set
+# CONFIG_ATM_ZATM is not set
+# CONFIG_ATM_NICSTAR is not set
+# CONFIG_ATM_IDT77252 is not set
+# CONFIG_ATM_AMBASSADOR is not set
+# CONFIG_ATM_HORIZON is not set
+# CONFIG_ATM_IA is not set
+# CONFIG_ATM_FORE200E_MAYBE is not set
+# CONFIG_ATM_HE is not set
# CONFIG_FDDI is not set
# CONFIG_HIPPI is not set
CONFIG_PPP=m
@@ -951,6 +975,7 @@ CONFIG_PPP_DEFLATE=m
CONFIG_PPP_BSDCOMP=m
CONFIG_PPP_MPPE=m
CONFIG_PPPOE=m
+CONFIG_PPPOATM=m
# CONFIG_SLIP is not set
# CONFIG_NET_FC is not set
# CONFIG_SHAPER is not set
@@ -1331,7 +1356,7 @@ CONFIG_USB_SERIAL_BELKIN=m
# CONFIG_USB_SERIAL_CYPRESS_M8 is not set
# CONFIG_USB_SERIAL_EMPEG is not set
CONFIG_USB_SERIAL_FTDI_SIO=m
-# CONFIG_USB_SERIAL_VISOR is not set
+CONFIG_USB_SERIAL_VISOR=m
# CONFIG_USB_SERIAL_IPAQ is not set
# CONFIG_USB_SERIAL_IR is not set
# CONFIG_USB_SERIAL_EDGEPORT is not set
@@ -1373,6 +1398,10 @@ CONFIG_USB_SERIAL_PL2303=m
#
# USB DSL modem support
#
+CONFIG_USB_ATM=m
+# CONFIG_USB_SPEEDTOUCH is not set
+# CONFIG_USB_CXACRU is not set
+# CONFIG_USB_XUSBATM is not set
#
# USB Gadget Support
diff --git a/target/linux/linux-2.6/config/x86 b/target/linux/linux-2.6/config/x86
index 33bbf4f226..8cb65cc735 100644
--- a/target/linux/linux-2.6/config/x86
+++ b/target/linux/linux-2.6/config/x86
@@ -488,6 +488,13 @@ CONFIG_IP_DCCP_TFRC_LIB=m
#
# CONFIG_IP_SCTP is not set
# CONFIG_ATM is not set
+CONFIG_ATM=m
+CONFIG_ATM_CLIP=m
+CONFIG_ATM_CLIP_NO_ICMP=y
+CONFIG_ATM_LANE=m
+CONFIG_ATM_MPOA=m
+CONFIG_ATM_BR2684=m
+CONFIG_ATM_BR2684_IPFILTER=y
CONFIG_BRIDGE=y
CONFIG_VLAN_8021Q=y
# CONFIG_DECNET is not set
@@ -1650,7 +1657,7 @@ CONFIG_USB_SERIAL_BELKIN=m
# CONFIG_USB_SERIAL_CYPRESS_M8 is not set
# CONFIG_USB_SERIAL_EMPEG is not set
CONFIG_USB_SERIAL_FTDI_SIO=m
-# CONFIG_USB_SERIAL_VISOR is not set
+CONFIG_USB_SERIAL_VISOR=m
# CONFIG_USB_SERIAL_IPAQ is not set
# CONFIG_USB_SERIAL_IR is not set
# CONFIG_USB_SERIAL_EDGEPORT is not set
@@ -1692,6 +1699,10 @@ CONFIG_USB_SERIAL_PL2303=m
#
# USB DSL modem support
#
+CONFIG_USB_ATM=m
+# CONFIG_USB_SPEEDTOUCH is not set
+# CONFIG_USB_CXACRU is not set
+# CONFIG_USB_XUSBATM is not set
#
# USB Gadget Support