aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-02 19:17:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-02 19:17:58 +0000
commita246e32c0d554bcddad0860d89e122d3298adb46 (patch)
tree3b673abc1650c1c731777e1d9c03c51ed57e938d /target
parentfa0ed4d09c5ba40e2945cae6d19249cb270e7778 (diff)
downloadupstream-a246e32c0d554bcddad0860d89e122d3298adb46.tar.gz
upstream-a246e32c0d554bcddad0860d89e122d3298adb46.tar.bz2
upstream-a246e32c0d554bcddad0860d89e122d3298adb46.zip
ramips: Make serial console for DIR-300-B1 work again
Make serial console for DIR-300-B1 work again. With some recent change, "console=ttyS1,57600" was removed from the default kernel command line, this adds the necessary mkcmdline incantation to image/Makefile to add it there for this target. This is quite likely broken for other targets as well. Without this the console switches to ttyS0 instead of ttyS1 and kernel output is missing, and the userspace comes up with 9600 baud instead of 57600. Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31556 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 3d4d64933b..88b20fa3d8 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -158,14 +158,14 @@ mtdlayout_dir300b1=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,896k(kernel),288
mtd_dir300b1_kernel_part_size=917504
mtd_dir300b1_rootfs_part_size=2949120
define BuildFirmware/DIR300B1
- $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
+ $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
mkwrgimg -s $(4) -d /dev/mtdblock/2 \
-i $(call sysupname,$(1),$(2)) \
-o $(call imgname,$(1),$(2))-factory.bin
endef
define BuildFirmware/DIR300B1/initramfs
- $(call BuildFirmware/Generic/initramfs,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
+ $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
endef
define BuildFirmware/Edimax