aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-09-16 10:12:08 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-09-16 10:12:08 +0000
commit83e249b09a03ca96fa1166ae07a6a543b21b81b9 (patch)
tree745ea60a86e55b3bed7b483b431836c5acea2b8d /target
parentb9a6e2df0bd792be081428055ce857278f47d07c (diff)
downloadupstream-83e249b09a03ca96fa1166ae07a6a543b21b81b9.tar.gz
upstream-83e249b09a03ca96fa1166ae07a6a543b21b81b9.tar.bz2
upstream-83e249b09a03ca96fa1166ae07a6a543b21b81b9.zip
use aligned trx for 128kb flash size for netgear, reported by Kaloz
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/image/brcm/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/image/brcm/Makefile b/target/linux/image/brcm/Makefile
index abba13101f..23072bde9b 100644
--- a/target/linux/image/brcm/Makefile
+++ b/target/linux/image/brcm/Makefile
@@ -30,12 +30,14 @@ $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
ifeq ($(KERNEL),2.6)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+ifneq ($(FS),jffs2-4MB)
$(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
dd if=$(BUILD_DIR)/loader.elf of=$@ bs=131072 conv=sync
cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
install: $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
endif
+endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))