aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-25 19:36:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-25 19:36:06 +0000
commit727297d99909392149bcc4809ac5df726fe3272b (patch)
tree2985d17358b321ea87ad61cef7f7d908f938e0a2 /target
parent628d8933661a4be693dd6e0493f78641efe3587b (diff)
downloadupstream-727297d99909392149bcc4809ac5df726fe3272b.tar.gz
upstream-727297d99909392149bcc4809ac5df726fe3272b.tar.bz2
upstream-727297d99909392149bcc4809ac5df726fe3272b.zip
rename openwrt-ar7-zimage.bin to openwrt-ar7-2.4-kernel.bin
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1569 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/image/ar7/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/image/ar7/Makefile b/target/linux/image/ar7/Makefile
index 6725302776..ee2b570eb7 100644
--- a/target/linux/image/ar7/Makefile
+++ b/target/linux/image/ar7/Makefile
@@ -40,7 +40,7 @@ $(KDIR)/vmlinux.gz: $(KDIR)/vmlinux
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-ar7-zimage.bin: $(KDIR)/vmlinux.lzma compile
+$(BIN_DIR)/openwrt-ar7-2.4-kernel.bin: $(KDIR)/vmlinux.lzma compile
$(TARGET_CROSS)ld -T $(PKG_BUILD_DIR)/zimage.script -r -b binary $< -o $(KDIR)/zimage.o
$(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=$(KERNEL_ENTRY) -T $(PKG_BUILD_DIR)/ld.script \
$(PKG_BUILD_DIR)/loader.o \
@@ -57,7 +57,7 @@ ifeq ($(FS),jffs2-4MB)
ALIGN:=bs=65536 conv=sync
endif
-$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-ar7-zimage.bin
+$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-ar7-2.4-kernel.bin
dd if=$< $(ALIGN) > $@
cat $(BUILD_DIR)/linux-$(KERNEL)-ar7/root.$(FS) >> $@
@@ -79,5 +79,5 @@ clean:
prepare: $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)/zimage.script $(PKG_BUILD_DIR)/ld.script
compile: prepare $(PKG_BUILD_DIR)/loader.o $(PKG_BUILD_DIR)/LzmaDecode.o $(PKG_BUILD_DIR)/srec2bin
-install: $(BIN_DIR)/openwrt-ar7-zimage.bin $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin
+install: $(BIN_DIR)/openwrt-ar7-2.4-kernel.bin $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin