aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-02 12:07:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-02 12:07:10 +0000
commit202a1d976a733cf50e17b460260cc4163ca5de68 (patch)
treeb765b593cf73f36892637e9517b810f671fed5a3 /target
parent7ce584788b99d96219b45596703cbfcf9791ff10 (diff)
downloadupstream-202a1d976a733cf50e17b460260cc4163ca5de68.tar.gz
upstream-202a1d976a733cf50e17b460260cc4163ca5de68.tar.bz2
upstream-202a1d976a733cf50e17b460260cc4163ca5de68.zip
AA: atheros: backport r36513
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36514 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/atheros/Makefile4
-rw-r--r--target/linux/atheros/patches-3.3/100-board.patch4
2 files changed, 3 insertions, 5 deletions
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index ce2a90dc96..7125f24550 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=3.3.8
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k gpioctl swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
define Target/Description
Build firmware images for Atheros SoC boards
diff --git a/target/linux/atheros/patches-3.3/100-board.patch b/target/linux/atheros/patches-3.3/100-board.patch
index aaa4d4193a..f51a59b760 100644
--- a/target/linux/atheros/patches-3.3/100-board.patch
+++ b/target/linux/atheros/patches-3.3/100-board.patch
@@ -2106,7 +2106,7 @@
+
--- /dev/null
+++ b/arch/mips/ar231x/ar2315.c
-@@ -0,0 +1,694 @@
+@@ -0,0 +1,692 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License. See the file "COPYING" in the main directory of this archive
@@ -2789,8 +2789,6 @@
+ if (!is_2315())
+ return;
+
-+ gpio_request(AR2315_RESET_GPIO, "reset");
-+
+ /* Clear any lingering AHB errors */
+ config = read_c0_config();
+ write_c0_config(config & ~0x3);