aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-02-19 13:00:30 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-02-19 13:00:30 +0000
commit1992d1fcbfe0c9af04618faff0593d41924c16d6 (patch)
treef4e652c161de4b02c34416cff43f59a96607c27a /target
parent78c027e7cc93b2794950a4d5be087c0021b65824 (diff)
downloadupstream-1992d1fcbfe0c9af04618faff0593d41924c16d6.tar.gz
upstream-1992d1fcbfe0c9af04618faff0593d41924c16d6.tar.bz2
upstream-1992d1fcbfe0c9af04618faff0593d41924c16d6.zip
demistifying make *clean targets, fix some clean targets issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@272 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/Makefile.in17
1 files changed, 10 insertions, 7 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index 2d23d8336a..40c9a0578b 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1,17 +1,20 @@
# Default target skeleton stuff, may be overridden
+DIST=openwrt
TARGET_SKELETON=target/default/skel.tar.gz
TARGET_SKEL_DIR=target/default/target_skeleton
include target/device/Makefile.in
-openwrt-linux.trx: openwrt-trx
- PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+$(DIST)-linux.trx: openwrt-trx
+ PATH=$(TARGET_PATH) trx -o $(DIST)-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
-openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
- PATH=$(TARGET_PATH) addpattern -2 -i openwrt-linux.trx -o openwrt-gs-code.bin -g
+$(DIST)-gs-code.bin: openwrt-addpattern $(DIST)-linux.trx
+ PATH=$(TARGET_PATH) addpattern -2 -i $(DIST)-linux.trx -o $(DIST)-gs-code.bin -g
-openwrt-g-code.bin: openwrt-gs-code.bin
- sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+$(DIST)-g-code.bin: $(DIST)-gs-code.bin
+ sed -e "1s,^W54S,W54G," < $(DIST)-gs-code.bin > $(DIST)-g-code.bin
-openwrt-image: openwrt openwrt-g-code.bin
+openwrt-image: openwrt $(DIST)-g-code.bin
+$(DIST)-image-clean:
+ @-rm $(DIST)-* 2>/dev/null