aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-04-01 14:51:48 +0000
committerNicolas Thill <nico@openwrt.org>2006-04-01 14:51:48 +0000
commit19161c86c691c891448993a650ccee35bd044d67 (patch)
treead1472f49024e8bf6a49c7a76e70ad039d19e603 /target
parent8b78b92a74a0412efaf0970db67ddeda300d68aa (diff)
downloadupstream-19161c86c691c891448993a650ccee35bd044d67.tar.gz
upstream-19161c86c691c891448993a650ccee35bd044d67.tar.bz2
upstream-19161c86c691c891448993a650ccee35bd044d67.zip
load of ide modules at boot (closes: #439)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3565 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/Config.in6
-rw-r--r--target/linux/generic-2.4/modules.mk2
2 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/Config.in b/target/linux/Config.in
index e81b099be7..7a416753ad 100644
--- a/target/linux/Config.in
+++ b/target/linux/Config.in
@@ -287,6 +287,12 @@ config BR2_PACKAGE_KMOD_IDE
help
Kernel modules for IDE support
useful for usb mass storage devices (e.g. on WL-HDD)
+
+ Includes:
+ - ide-core
+ - ide-detect
+ - ide-disk
+ - pdc202xx_old
config BR2_PACKAGE_KMOD_LOOP
prompt "kmod-loop......................... Loop mount support"
diff --git a/target/linux/generic-2.4/modules.mk b/target/linux/generic-2.4/modules.mk
index 705b702e83..f35e9ba56b 100644
--- a/target/linux/generic-2.4/modules.mk
+++ b/target/linux/generic-2.4/modules.mk
@@ -110,7 +110,7 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
$(eval $(call KMOD_template,IDE,ide,\
$(MODULES_DIR)/kernel/drivers/ide/*.o \
$(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE))
+,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
$(eval $(call KMOD_template,LOOP,loop,\
$(MODULES_DIR)/kernel/drivers/block/loop.o \