aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-04 15:16:07 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-04 16:59:22 +0100
commit2a832b3df5990f33aa3d5944733e43bf5287475c (patch)
tree205a4a2cc0956ef685b92b1b4fc611528627a367 /target/sdk
parenta7c0d7c06c5b353c98f6db6b0b766d2ff3dd6887 (diff)
downloadupstream-2a832b3df5990f33aa3d5944733e43bf5287475c.tar.gz
upstream-2a832b3df5990f33aa3d5944733e43bf5287475c.tar.bz2
upstream-2a832b3df5990f33aa3d5944733e43bf5287475c.zip
llvm-bpf: support creating a tarball in bin
This can be used for adding the toolchain to an existing tree without having to build it from scratch. Enable building the toolchain + tarball by default on buildbot Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Config.in9
-rw-r--r--target/sdk/Makefile3
2 files changed, 10 insertions, 2 deletions
diff --git a/target/sdk/Config.in b/target/sdk/Config.in
index 0c8a61d247..1984e242e7 100644
--- a/target/sdk/Config.in
+++ b/target/sdk/Config.in
@@ -7,4 +7,11 @@ config SDK
with a precompiled toolchain. It can be used to develop and
test packages for OpenWrt before including them in the buildroot
-
+config SDK_LLVM_BPF
+ bool "Build the LLVM-BPF toolchain tarball"
+ depends on BPF_TOOLCHAIN_BUILD_LLVM
+ default BUILDBOT
+ help
+ This is a tarball of the precompiled LLVM toolchain suitable
+ for unpacking into the buildroot/SDK. It is used to build packages
+ that ship with eBPF kernel modules
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 0606621192..7d7f09b514 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -34,7 +34,8 @@ EXCLUDE_DIRS:= \
*.install.flags \
*.install \
*/doc \
- */share/locale
+ */share/locale \
+ */llvm-bpf*
SDK_DIRS = \
$(STAGING_SUBDIR_HOST) \