aboutsummaryrefslogtreecommitdiffstats
path: root/target/lzma-loader/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-02 19:06:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-02 19:06:50 +0000
commitdae7e90107f09031e05500e09a238dc7445d78bf (patch)
tree4d80baf37b57ec311461834e82db4a7053417ca9 /target/lzma-loader/patches
parent786263062955ddd4591994801a833a2d10cee8b6 (diff)
downloadupstream-dae7e90107f09031e05500e09a238dc7445d78bf.tar.gz
upstream-dae7e90107f09031e05500e09a238dc7445d78bf.tar.bz2
upstream-dae7e90107f09031e05500e09a238dc7445d78bf.zip
remove lzma loader config option (make it default) and move it from package/ to target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/lzma-loader/patches')
-rw-r--r--target/lzma-loader/patches/toolchain.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/lzma-loader/patches/toolchain.patch b/target/lzma-loader/patches/toolchain.patch
new file mode 100644
index 0000000000..69617056b3
--- /dev/null
+++ b/target/lzma-loader/patches/toolchain.patch
@@ -0,0 +1,12 @@
+--- loader-0.03/Makefile 2005-03-28 22:15:24.569677129 +0400
++++ loader/Makefile 2005-03-28 22:16:42.339989214 +0400
+@@ -24,7 +24,8 @@
+
+ CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
+ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
+- -ffunction-sections -pipe -mcpu=r4600 -mips2 -Wa,--trap -m4710a0kern
++ -ffunction-sections -pipe -mlong-calls -fno-common \
++ -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+ CFLAGS += -DLOADADDR=$(TEXT_START) -D_LZMA_IN_CB
+
+ ASFLAGS = $(CFLAGS) -D__ASSEMBLY__ -DBZ_TEXT_START=$(BZ_TEXT_START)