aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorKevin Jilissen <info@kevinjilissen.nl>2023-10-08 16:56:40 +0200
committerSander Vanheule <sander@svanheule.net>2023-10-14 20:14:51 +0200
commit2ce5521bd20213a42bfa655a4ae178ee0a97baba (patch)
tree0aaab3d1a29d8ecb86180869218374668cf3afd8 /target/linux
parent0bc33a6505e31d96a016c11be6b0fb37564b3e92 (diff)
downloadupstream-2ce5521bd20213a42bfa655a4ae178ee0a97baba.tar.gz
upstream-2ce5521bd20213a42bfa655a4ae178ee0a97baba.tar.bz2
upstream-2ce5521bd20213a42bfa655a4ae178ee0a97baba.zip
realtek: rename hpe,1920-8g-poe to match hardware
There are two hardware models of the HPE 1920-8g-poe switch. The version currently in the repository is the model with a PoE budget of 180W. In preparation of the addition of the 65W model, the existing model is renamed to clarify the hardware version it targets. As suggested by Pawel, the 'SUPPORTED_DEVICES' includes the old target name to enable an upgrade path of builds with the old name. Suggested-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Kevin Jilissen <info@kevinjilissen.nl> (cherry picked from commit 987c96e88927094ff61e83870f872f0560d8e5c1)
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/realtek/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/realtek/base-files/etc/board.d/03_gpio_switches2
-rw-r--r--target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-180w.dts (renamed from target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe.dts)4
-rw-r--r--target/linux/realtek/image/rtl838x.mk7
4 files changed, 9 insertions, 8 deletions
diff --git a/target/linux/realtek/base-files/etc/board.d/02_network b/target/linux/realtek/base-files/etc/board.d/02_network
index 90b45abf94..84d3e68e48 100644
--- a/target/linux/realtek/base-files/etc/board.d/02_network
+++ b/target/linux/realtek/base-files/etc/board.d/02_network
@@ -31,7 +31,7 @@ lan_mac_end=""
label_mac=""
case $board in
hpe,1920-8g|\
-hpe,1920-8g-poe|\
+hpe,1920-8g-poe-180w|\
hpe,1920-16g|\
hpe,1920-24g)
label_mac=$(mtd_get_mac_binary factory 0x68)
@@ -67,7 +67,7 @@ done
[ -n "$label_mac" ] && ucidef_set_label_macaddr $label_mac
case $board in
-hpe,1920-8g-poe)
+hpe,1920-8g-poe-180w)
ucidef_set_poe 180 "$lan_list_rev" "lan9 lan10"
;;
netgear,gs110tpp-v1)
diff --git a/target/linux/realtek/base-files/etc/board.d/03_gpio_switches b/target/linux/realtek/base-files/etc/board.d/03_gpio_switches
index abfcb8e592..1e49d89c64 100644
--- a/target/linux/realtek/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/realtek/base-files/etc/board.d/03_gpio_switches
@@ -6,7 +6,7 @@ board_config_update
board=$(board_name)
case "$board" in
-hpe,1920-8g-poe)
+hpe,1920-8g-poe-180w)
ucidef_add_gpio_switch "fan_ctrl" "Fan control" "456" "0"
;;
esac
diff --git a/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe.dts b/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-180w.dts
index 3b00c31411..6398e6d034 100644
--- a/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe.dts
+++ b/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-180w.dts
@@ -3,8 +3,8 @@
#include "rtl8380_hpe_1920-8g.dtsi"
/ {
- compatible = "hpe,1920-8g-poe", "realtek,rtl838x-soc";
- model = "HPE 1920-8G-PoE+ (JG922A)";
+ compatible = "hpe,1920-8g-poe-180w", "realtek,rtl838x-soc";
+ model = "HPE 1920-8G-PoE+ 180W (JG922A)";
};
&uart1 {
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index 73930f4d6f..c0b9c70bb6 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -99,13 +99,14 @@ define Device/hpe_1920-8g
endef
TARGET_DEVICES += hpe_1920-8g
-define Device/hpe_1920-8g-poe
+define Device/hpe_1920-8g-poe-180w
$(Device/hpe_1920)
SOC := rtl8380
- DEVICE_MODEL := 1920-8G-PoE+ (JG922A)
+ DEVICE_MODEL := 1920-8G-PoE+ 180W (JG922A)
H3C_DEVICE_ID := 0x00010025
+ SUPPORTED_DEVICES += hpe_1920-8g-poe
endef
-TARGET_DEVICES += hpe_1920-8g-poe
+TARGET_DEVICES += hpe_1920-8g-poe-180w
define Device/hpe_1920-16g
$(Device/hpe_1920)