aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>2022-12-30 15:30:52 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-06 17:53:10 +0100
commitdbebfb88b543fb1842e6af806d3bf2245fddff14 (patch)
tree66fcab8d7a90672ed0e43c60c327aaea852e6f26 /target/linux
parent4eeecf41cf4a855a07b3df57890a6f6528f00e36 (diff)
downloadupstream-dbebfb88b543fb1842e6af806d3bf2245fddff14.tar.gz
upstream-dbebfb88b543fb1842e6af806d3bf2245fddff14.tar.bz2
upstream-dbebfb88b543fb1842e6af806d3bf2245fddff14.zip
ramips: add support for Keenetic KN-1613
Keenetic KN-1613 is a 2.4/5 Ghz band 11ac (Wi-Fi 5) router, based on MT7628AN. Specification: - System-On-Chip: MT7628AN - CPU/Speed: 580 MHz - Flash-Chip: Winbond w25q256 - Flash size: 32768 KiB - RAM: 128 MiB - 4x 10/100 Mbps Ethernet - 2x external, non-detachable antennas - UART (J1) header on PCB (115200 8n1) - Wireless No1 (2T2R): SoC Built-in 2.4 GHz 802.11bgn - Wireless No2 (2T2R): MT7613BE 5 GHz 802.11ac - 4x LED, 2x button, 1x mode switch Notes: - The device supports dual boot mode - The firmware partitions were concatinated into one - The FN button led indicator has been reassigned as the 2.4GHz wifi indicator. Flash instruction: The only way to flash OpenWrt image is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24 and tftp server. 2. Rename "openwrt-ramips-mt76x8-keenetic_kn-1613-squashfs-factory.bin" to "KN-1613_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed until power led start blinking. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7628an_keenetic_kn-1613.dts223
-rw-r--r--target/linux/ramips/image/mt76x8.mk12
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/02_network12
4 files changed, 246 insertions, 4 deletions
diff --git a/target/linux/ramips/dts/mt7628an_keenetic_kn-1613.dts b/target/linux/ramips/dts/mt7628an_keenetic_kn-1613.dts
new file mode 100644
index 0000000000..4281682503
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_keenetic_kn-1613.dts
@@ -0,0 +1,223 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "keenetic,kn-1613", "mediatek,mt7628an-soc";
+ model = "Keenetic KN-1613";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "green:power";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ internet {
+ label = "green:internet";
+ gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi2 {
+ label = "green:wifi2";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wifi5 {
+ label = "green:wifi5";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ fn {
+ label = "fn";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ virtual_flash {
+ compatible = "mtd-concat";
+ devices = <&firmware1 &firmware2>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x0 0x1ec0000>;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "i2s", "i2c", "gpio", "refclk", "wdt", "wled_an";
+ function = "gpio";
+ };
+};
+
+&usbphy {
+ status = "disabled";
+};
+
+&ehci {
+ status = "disabled";
+};
+
+&ohci {
+ status = "disabled";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <32000000>;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-config";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "rf-eeprom";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ firmware1: partition@50000 {
+ label = "firmware_1";
+ reg = <0x50000 0xf60000>;
+ };
+
+ partition@fb0000 {
+ label = "config_1";
+ reg = <0xfb0000 0x40000>;
+ read-only;
+ };
+
+ partition@ff0000 {
+ label = "dump";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+
+ partition@1000000 {
+ label = "u-state";
+ reg = <0x1000000 0x30000>;
+ read-only;
+ };
+
+ partition@1030000 {
+ label = "u-config_res";
+ reg = <0x1030000 0x10000>;
+ read-only;
+ };
+
+ partition@1040000 {
+ label = "rf-eeprom_res";
+ reg = <0x1040000 0x10000>;
+ read-only;
+ };
+
+ firmware2: partition@1050000 {
+ label = "firmware_2";
+ reg = <0x1050000 0xf60000>;
+ };
+
+ partition@1fb0000 {
+ label = "config_2";
+ reg = <0x1fb0000 0x40000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&ethernet {
+ nvmem-cells = <&macaddr_factory_4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&esw {
+ mediatek,portmap = <0x3e>;
+};
+
+&wmac {
+ status = "okay";
+
+ mediatek,mtd-eeprom = <&factory 0x0>;
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0400>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&factory {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_4: macaddr@4 {
+ reg = <0x4 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index a77f1c97e1..9db2d9e60c 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -320,6 +320,18 @@ define Device/jotale_js76x8-32m
endef
TARGET_DEVICES += jotale_js76x8-32m
+define Device/keenetic_kn-1613
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 31488k
+ DEVICE_VENDOR := Keenetic
+ DEVICE_MODEL := KN-1613
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to $$$$(BLOCKSIZE) | \
+ check-size | zyimage -d 0x801613 -v "KN-1613"
+endef
+TARGET_DEVICES += keenetic_kn-1613
+
define Device/kroks_kndrt31r16
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Kroks
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
index 66628cea09..d972762dad 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
@@ -53,6 +53,9 @@ hiwifi,hc5661a|\
hiwifi,hc5761a)
ucidef_set_led_switch "internet" "internet" "blue:internet" "switch0" "0x10"
;;
+keenetic,kn-1613)
+ ucidef_set_led_switch "internet" "internet" "green:internet" "switch0" "0x01"
+ ;;
mediatek,linkit-smart-7688)
ucidef_set_led_wlan "wifi" "wifi" "orange:wifi" "phy0tpt"
;;
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index 26415e0fa6..7570999a4e 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -118,6 +118,11 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "6@eth0"
;;
+ keenetic,kn-1613|\
+ motorola,mwr03)
+ ucidef_add_switch "switch0" \
+ "1:lan" "2:lan" "3:lan" "0:wan" "6@eth0"
+ ;;
kroks,kndrt31r19)
ucidef_add_switch "switch0" \
"0:lan" "6@eth0"
@@ -129,10 +134,6 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4:wan" "6@eth0"
;;
- motorola,mwr03)
- ucidef_add_switch "switch0" \
- "1:lan" "2:lan" "3:lan" "0:wan" "6@eth0"
- ;;
netgear,r6020|\
netgear,r6080|\
netgear,r6120|\
@@ -252,6 +253,9 @@ ramips_setup_macs()
totolink,lr1200)
wan_mac=$(mtd_get_mac_binary factory 0x2e)
;;
+ keenetic,kn-1613)
+ wan_mac=$(mtd_get_mac_binary rf-eeprom 0x28)
+ ;;
linksys,e5400)
wan_mac=$(mtd_get_mac_binary factory 0x22)
;;