aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorSven Wegener <sven.wegener@stealer.net>2022-05-02 22:13:14 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-09-11 20:26:42 +0100
commit53fc987b25524c28525313347f0e2e5653dce43c (patch)
treef7db0c9ca125edef971d79ddf116b7d466a1b2ae /target/linux
parent76198e8f09a607c6aca2621f59d7a4cd7f6653e3 (diff)
downloadupstream-53fc987b25524c28525313347f0e2e5653dce43c.tar.gz
upstream-53fc987b25524c28525313347f0e2e5653dce43c.tar.bz2
upstream-53fc987b25524c28525313347f0e2e5653dce43c.zip
generic: move ledbar driver from mediatek target
This moves the ledbar driver to generic, to be also used by the ramips target. Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic/config-5.101
-rw-r--r--target/linux/generic/config-5.151
-rw-r--r--target/linux/generic/files/drivers/leds/leds-ubnt-ledbar.c (renamed from target/linux/mediatek/files/drivers/leds/leds-ubnt-ledbar.c)0
-rw-r--r--target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch29
-rw-r--r--target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch (renamed from target/linux/mediatek/patches-5.15/800-ubnt-ledbar-driver.patch)0
5 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index 7e9eb6143a..392de3095f 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -3042,6 +3042,7 @@ CONFIG_LEDS_TRIGGER_NETDEV=y
CONFIG_LEDS_TRIGGER_TIMER=y
# CONFIG_LEDS_TRIGGER_TRANSIENT is not set
# CONFIG_LEDS_TURRIS_OMNIA is not set
+# CONFIG_LEDS_UBNT_LEDBAR is not set
# CONFIG_LEDS_USER is not set
# CONFIG_LED_TRIGGER_PHY is not set
# CONFIG_LEGACY_PTYS is not set
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index f188ce36ac..596485f2f7 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -3143,6 +3143,7 @@ CONFIG_LEDS_TRIGGER_TIMER=y
# CONFIG_LEDS_TRIGGER_TRANSIENT is not set
# CONFIG_LEDS_TRIGGER_TTY is not set
# CONFIG_LEDS_TURRIS_OMNIA is not set
+# CONFIG_LEDS_UBNT_LEDBAR is not set
# CONFIG_LEDS_USER is not set
# CONFIG_LED_TRIGGER_PHY is not set
# CONFIG_LEGACY_PTYS is not set
diff --git a/target/linux/mediatek/files/drivers/leds/leds-ubnt-ledbar.c b/target/linux/generic/files/drivers/leds/leds-ubnt-ledbar.c
index 555340c5e8..555340c5e8 100644
--- a/target/linux/mediatek/files/drivers/leds/leds-ubnt-ledbar.c
+++ b/target/linux/generic/files/drivers/leds/leds-ubnt-ledbar.c
diff --git a/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch b/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
new file mode 100644
index 0000000000..92264eedf9
--- /dev/null
+++ b/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
@@ -0,0 +1,29 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -929,6 +929,16 @@ config LEDS_ACER_A500
+ This option enables support for the Power Button LED of
+ Acer Iconia Tab A500.
+
++config LEDS_UBNT_LEDBAR
++ tristate "LED support for Ubiquiti UniFi 6 LR"
++ depends on LEDS_CLASS && I2C && OF
++ help
++ This option enables support for the Ubiquiti LEDBAR
++ LED driver.
++
++ To compile this driver as a module, choose M here: the module
++ will be called leds-ubnt-ledbar.
++
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
++obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o
diff --git a/target/linux/mediatek/patches-5.15/800-ubnt-ledbar-driver.patch b/target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch
index 146e6ae2f5..146e6ae2f5 100644
--- a/target/linux/mediatek/patches-5.15/800-ubnt-ledbar-driver.patch
+++ b/target/linux/generic/hack-5.15/800-ubnt-ledbar-driver.patch