aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-08-31 11:13:38 +0200
committerRafał Miłecki <rafal@milecki.pl>2021-08-31 11:41:04 +0200
commit9b40346328aeb0c46ffb62f6c64f7fd64e909b98 (patch)
treeeb2556414ffc123057386c0be3fc9f45d040ec1b /target/linux
parent62465c75be43dc97fd5a94223dfbc226e0dfa6ba (diff)
downloadupstream-9b40346328aeb0c46ffb62f6c64f7fd64e909b98.tar.gz
upstream-9b40346328aeb0c46ffb62f6c64f7fd64e909b98.tar.bz2
upstream-9b40346328aeb0c46ffb62f6c64f7fd64e909b98.zip
bcm53xx: fix kmod-i2c-bcm-iproc for kernel 5.10
I2C_BCM_IPROC selects I2C_SLAVE which in turn makes two new symbols available: I2C_SLAVE_EEPROM and I2C_SLAVE_TESTUNIT. That was causing: I2C support (I2C) [M/n/y/?] m Enable compatibility bits for old user-space (I2C_COMPAT) [N/y/?] n I2C device interface (I2C_CHARDEV) [M/n/?] m I2C bus multiplexing support (I2C_MUX) [N/m/?] n Autoselect pertinent helper modules (I2C_HELPER_AUTO) [N/y/?] n SMBus-specific protocols (I2C_SMBUS) [N/m/?] n I2C/SMBus Test Stub (I2C_STUB) [N/m/?] n I2C slave support (I2C_SLAVE) [Y/?] y I2C eeprom slave driver (I2C_SLAVE_EEPROM) [N/m/?] n I2C eeprom testunit driver (I2C_SLAVE_TESTUNIT) [N/m/?] (NEW) Ideally I2C_SLAVE should probably be packaged as kmod-i2c-slabe. For now just modify kmod-i2c-bcm-iproc to fix kernel compilation. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/bcm53xx/modules.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/modules.mk b/target/linux/bcm53xx/modules.mk
index e43231f376..4b28923d8b 100644
--- a/target/linux/bcm53xx/modules.mk
+++ b/target/linux/bcm53xx/modules.mk
@@ -36,7 +36,9 @@ $(eval $(call KernelPackage,phy-bcm-ns-usb3))
define KernelPackage/i2c-bcm-iproc
TITLE:=Broadcom iProc I2C controller
- KCONFIG:=CONFIG_I2C_BCM_IPROC
+ KCONFIG:= \
+ CONFIG_I2C_BCM_IPROC \
+ CONFIG_I2C_SLAVE_TESTUNIT=n
DEPENDS:=@TARGET_bcm53xx +kmod-i2c-core
SUBMENU:=$(I2C_MENU)
FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-bcm-iproc.ko