aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-09-30 18:36:23 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-10-05 23:30:48 +0300
commit6f787b62d0a206db36540421b80ec5530b49bde2 (patch)
tree696a388f35bf8787bc1688c93cd62131b13fa47d /target/linux
parent297cb8c147fe66503c3772fdf46caa01ee2fb161 (diff)
downloadupstream-6f787b62d0a206db36540421b80ec5530b49bde2.tar.gz
upstream-6f787b62d0a206db36540421b80ec5530b49bde2.tar.bz2
upstream-6f787b62d0a206db36540421b80ec5530b49bde2.zip
bcm27xx: add SND_SOC_AD193X_{I2C,SPI} symbols
When building an image for the bcm27xx target, some combinations of config options will fail to build due the SND_SOC_AD193X_I2C and SND_SOC_AD193X_SPI kernel config symbols being missing. The problem only occurs on bcm27xx as the target contains a patch that modifies the Kconfig file containing the symbols; in the vanilla kernel, there is no string after the tristate keyword so the symbol is not exposed. The _I2C symbol depends on I2C, which is enabled in the kernel configs of all bcm27xx subtargets. The _SPI symbol depends on SPI_MASTER, which is exposed by either kmod-mmc-spi, kmod-spi-bitbang, kmod-spi-dev, kmod-spi-bcm2835 or kmod-spi-bcm2835-aux. Both symbols are defined in the sound/soc/codecs directory, which is only included when SND_SOC is enabled, so this problem doesn't occur when kmod-sound-soc-core is not enabled. As the kmod-sound-soc-bcm2835-i2s package disables the SND_SOC_AD193X_SPI symbol, it also doesn't occur when kmod-sound-soc-bcm2835-i2s is enabled. As there are several possible config combinations that do exhibit this problem, it is best to solve it by adding the missing symbols to the subtarget kernel configs. By doing this we can remove them from the kmod-sound-soc-bcm2835-i2s package. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/bcm27xx/bcm2708/config-5.102
-rw-r--r--target/linux/bcm27xx/bcm2708/config-5.42
-rw-r--r--target/linux/bcm27xx/bcm2709/config-5.102
-rw-r--r--target/linux/bcm27xx/bcm2709/config-5.42
-rw-r--r--target/linux/bcm27xx/bcm2710/config-5.102
-rw-r--r--target/linux/bcm27xx/bcm2710/config-5.42
-rw-r--r--target/linux/bcm27xx/bcm2711/config-5.102
-rw-r--r--target/linux/bcm27xx/bcm2711/config-5.42
-rw-r--r--target/linux/bcm27xx/modules/sound.mk2
9 files changed, 16 insertions, 2 deletions
diff --git a/target/linux/bcm27xx/bcm2708/config-5.10 b/target/linux/bcm27xx/bcm2708/config-5.10
index 094765abdc..12567abb24 100644
--- a/target/linux/bcm27xx/bcm2708/config-5.10
+++ b/target/linux/bcm27xx/bcm2708/config-5.10
@@ -321,6 +321,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
CONFIG_SMSC_PHY=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSE_IRQ=y
CONFIG_SRCU=y
# CONFIG_STRIP_ASM_SYMS is not set
diff --git a/target/linux/bcm27xx/bcm2708/config-5.4 b/target/linux/bcm27xx/bcm2708/config-5.4
index ef71076497..42203d2587 100644
--- a/target/linux/bcm27xx/bcm2708/config-5.4
+++ b/target/linux/bcm27xx/bcm2708/config-5.4
@@ -309,6 +309,8 @@ CONFIG_SERIAL_DEV_BUS=y
CONFIG_SERIAL_MCTRL_GPIO=y
CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSE_IRQ=y
CONFIG_SRCU=y
# CONFIG_STRIP_ASM_SYMS is not set
diff --git a/target/linux/bcm27xx/bcm2709/config-5.10 b/target/linux/bcm27xx/bcm2709/config-5.10
index 5b6c8b7edd..3986cffec2 100644
--- a/target/linux/bcm27xx/bcm2709/config-5.10
+++ b/target/linux/bcm27xx/bcm2709/config-5.10
@@ -402,6 +402,8 @@ CONFIG_SG_POOL=y
CONFIG_SMP=y
CONFIG_SMP_ON_UP=y
CONFIG_SMSC_PHY=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSE_IRQ=y
CONFIG_SRCU=y
# CONFIG_STRIP_ASM_SYMS is not set
diff --git a/target/linux/bcm27xx/bcm2709/config-5.4 b/target/linux/bcm27xx/bcm2709/config-5.4
index 4118d0f684..4392674371 100644
--- a/target/linux/bcm27xx/bcm2709/config-5.4
+++ b/target/linux/bcm27xx/bcm2709/config-5.4
@@ -399,6 +399,8 @@ CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
CONFIG_SMP=y
CONFIG_SMP_ON_UP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSE_IRQ=y
CONFIG_SRCU=y
# CONFIG_STRIP_ASM_SYMS is not set
diff --git a/target/linux/bcm27xx/bcm2710/config-5.10 b/target/linux/bcm27xx/bcm2710/config-5.10
index 66c9ff9f0a..5dfdab8987 100644
--- a/target/linux/bcm27xx/bcm2710/config-5.10
+++ b/target/linux/bcm27xx/bcm2710/config-5.10
@@ -389,6 +389,8 @@ CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
CONFIG_SMP=y
CONFIG_SMSC_PHY=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSEMEM=y
CONFIG_SPARSEMEM_EXTREME=y
CONFIG_SPARSEMEM_MANUAL=y
diff --git a/target/linux/bcm27xx/bcm2710/config-5.4 b/target/linux/bcm27xx/bcm2710/config-5.4
index f2702a6d62..6d1133980a 100644
--- a/target/linux/bcm27xx/bcm2710/config-5.4
+++ b/target/linux/bcm27xx/bcm2710/config-5.4
@@ -391,6 +391,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
CONFIG_SMP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSEMEM=y
CONFIG_SPARSEMEM_EXTREME=y
CONFIG_SPARSEMEM_MANUAL=y
diff --git a/target/linux/bcm27xx/bcm2711/config-5.10 b/target/linux/bcm27xx/bcm2711/config-5.10
index d309a3a760..1829a5c29c 100644
--- a/target/linux/bcm27xx/bcm2711/config-5.10
+++ b/target/linux/bcm27xx/bcm2711/config-5.10
@@ -400,6 +400,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
CONFIG_SMP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSEMEM=y
CONFIG_SPARSEMEM_EXTREME=y
CONFIG_SPARSEMEM_MANUAL=y
diff --git a/target/linux/bcm27xx/bcm2711/config-5.4 b/target/linux/bcm27xx/bcm2711/config-5.4
index 5548a960ab..f9b172e7d6 100644
--- a/target/linux/bcm27xx/bcm2711/config-5.4
+++ b/target/linux/bcm27xx/bcm2711/config-5.4
@@ -403,6 +403,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
CONFIG_SERIAL_OF_PLATFORM=y
CONFIG_SG_POOL=y
CONFIG_SMP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
CONFIG_SPARSEMEM=y
CONFIG_SPARSEMEM_EXTREME=y
CONFIG_SPARSEMEM_MANUAL=y
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index 5073e5ff50..a6b1d73987 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -26,8 +26,6 @@ define KernelPackage/sound-soc-bcm2835-i2s
TITLE:=SoC Audio support for the Broadcom 2835 I2S module
KCONFIG:= \
CONFIG_SND_BCM2835_SOC_I2S \
- CONFIG_SND_SOC_AD193X_SPI=n \
- CONFIG_SND_SOC_AD193X_I2C=n \
CONFIG_SND_SOC_DMAENGINE_PCM=y \
CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y
FILES:= \