aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-10-13 11:02:37 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-21 00:17:36 +0200
commit3bd701d47cb76e552a3378900699b76ad4900df0 (patch)
tree442fb6e3664925fcb89bda293c58e5d8f5026649 /target/linux
parent0ea33e5363f8a544a4c41c89cc1ca0d6b0d91e2e (diff)
downloadupstream-3bd701d47cb76e552a3378900699b76ad4900df0.tar.gz
upstream-3bd701d47cb76e552a3378900699b76ad4900df0.tar.bz2
upstream-3bd701d47cb76e552a3378900699b76ad4900df0.zip
kernel: bump 5.10 to 5.10.73
Patches automatically refreshed. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/x86/patches-5.10/101-v5.15-mfd-lpc_ich-Enable-GPIO-driver-for-DH89xxCC.patch6
-rw-r--r--target/linux/x86/patches-5.10/102-v5.15-platform-x86-add-meraki-mx100-platform-driver.patch17
2 files changed, 5 insertions, 18 deletions
diff --git a/target/linux/x86/patches-5.10/101-v5.15-mfd-lpc_ich-Enable-GPIO-driver-for-DH89xxCC.patch b/target/linux/x86/patches-5.10/101-v5.15-mfd-lpc_ich-Enable-GPIO-driver-for-DH89xxCC.patch
index 0f0a3958da..b4881bf1d3 100644
--- a/target/linux/x86/patches-5.10/101-v5.15-mfd-lpc_ich-Enable-GPIO-driver-for-DH89xxCC.patch
+++ b/target/linux/x86/patches-5.10/101-v5.15-mfd-lpc_ich-Enable-GPIO-driver-for-DH89xxCC.patch
@@ -16,11 +16,9 @@ Signed-off-by: Lee Jones <lee.jones@linaro.org>
drivers/mfd/lpc_ich.c | 1 +
1 file changed, 1 insertion(+)
-diff --git a/drivers/mfd/lpc_ich.c b/drivers/mfd/lpc_ich.c
-index 3bbb29a7e7a57..f10e53187f67a 100644
--- a/drivers/mfd/lpc_ich.c
+++ b/drivers/mfd/lpc_ich.c
-@@ -489,6 +489,7 @@ static struct lpc_ich_info lpc_chipset_info[] = {
+@@ -489,6 +489,7 @@ static struct lpc_ich_info lpc_chipset_i
[LPC_DH89XXCC] = {
.name = "DH89xxCC",
.iTCO_version = 2,
@@ -28,5 +26,3 @@ index 3bbb29a7e7a57..f10e53187f67a 100644
},
[LPC_PPT] = {
.name = "Panther Point",
---
-cgit 1.2.3-1.el7
diff --git a/target/linux/x86/patches-5.10/102-v5.15-platform-x86-add-meraki-mx100-platform-driver.patch b/target/linux/x86/patches-5.10/102-v5.15-platform-x86-add-meraki-mx100-platform-driver.patch
index c05b61a994..0babc73b06 100644
--- a/target/linux/x86/patches-5.10/102-v5.15-platform-x86-add-meraki-mx100-platform-driver.patch
+++ b/target/linux/x86/patches-5.10/102-v5.15-platform-x86-add-meraki-mx100-platform-driver.patch
@@ -22,11 +22,9 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
3 files changed, 246 insertions(+)
create mode 100644 drivers/platform/x86/meraki-mx100.c
-diff --git a/drivers/platform/x86/Kconfig b/drivers/platform/x86/Kconfig
-index 6ad35158ae4ef..432d72170b003 100644
--- a/drivers/platform/x86/Kconfig
+++ b/drivers/platform/x86/Kconfig
-@@ -302,6 +302,19 @@ config ASUS_NB_WMI
+@@ -267,6 +267,19 @@ config ASUS_NB_WMI
If you have an ACPI-WMI compatible Asus Notebook, say Y or M
here.
@@ -46,11 +44,9 @@ index 6ad35158ae4ef..432d72170b003 100644
config EEEPC_LAPTOP
tristate "Eee PC Hotkey Driver"
depends on ACPI
-diff --git a/drivers/platform/x86/Makefile b/drivers/platform/x86/Makefile
-index 5edfdc2ea7f29..9bb3c3f773864 100644
--- a/drivers/platform/x86/Makefile
+++ b/drivers/platform/x86/Makefile
-@@ -39,6 +39,9 @@ obj-$(CONFIG_ASUS_NB_WMI) += asus-nb-wmi.o
+@@ -33,6 +33,9 @@ obj-$(CONFIG_ASUS_NB_WMI) += asus-nb-wmi
obj-$(CONFIG_EEEPC_LAPTOP) += eeepc-laptop.o
obj-$(CONFIG_EEEPC_WMI) += eeepc-wmi.o
@@ -58,11 +54,8 @@ index 5edfdc2ea7f29..9bb3c3f773864 100644
+obj-$(CONFIG_MERAKI_MX100) += meraki-mx100.o
+
# Dell
- obj-$(CONFIG_X86_PLATFORM_DRIVERS_DELL) += dell/
-
-diff --git a/drivers/platform/x86/meraki-mx100.c b/drivers/platform/x86/meraki-mx100.c
-new file mode 100644
-index 0000000000000..3751ed36a980a
+ obj-$(CONFIG_DCDBAS) += dcdbas.o
+ obj-$(CONFIG_DELL_SMBIOS) += dell-smbios.o
--- /dev/null
+++ b/drivers/platform/x86/meraki-mx100.c
@@ -0,0 +1,230 @@
@@ -296,5 +289,3 @@ index 0000000000000..3751ed36a980a
+MODULE_DESCRIPTION("Cisco Meraki MX100 Platform Driver");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("platform:meraki-mx100");
---
-cgit 1.2.3-1.el7