aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-06-07 13:26:43 +0200
committerPaul Spooren <mail@aparcar.org>2022-07-29 15:10:21 +0200
commitf94b30d83c2aa401b3ff9c4914bb2ef6386df8aa (patch)
treefe481e2f551f0cd48a1e62b82585fe58786b5ac0 /target/linux
parent09dae4feac941f3a6190cf361479bf8b2ba194bf (diff)
downloadupstream-f94b30d83c2aa401b3ff9c4914bb2ef6386df8aa.tar.gz
upstream-f94b30d83c2aa401b3ff9c4914bb2ef6386df8aa.tar.bz2
upstream-f94b30d83c2aa401b3ff9c4914bb2ef6386df8aa.zip
octeon: add SUPPORTED_DEVICES to er/erlite
Using the BOARD_NAME variable results for both er and erlite devices to identify themselfs as `er` and `erlite` (via `ubus call system board`). This is problematic when devices search for firmware upgrades since the OpenWrt profile is actually called `ubnt_edgerouter` and `ubnt_edgerouter-lite`. By adding the `SUPPORTED_DEVICE` a mapping is created to point devices called `er` or `erlite` to the corresponding profile. FIXES: https://github.com/openwrt/asu/issues/348 Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 2a07270180ed0e295d854d6e9e59c78c40549efc)
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 11da22df3b..29a5eb9183 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -48,6 +48,7 @@ define Device/ubnt_edgerouter
DEVICE_MODEL := EdgeRouter
BOARD_NAME := er
CMDLINE := $(ER_CMDLINE)
+ SUPPORTED_DEVICES += er
endef
TARGET_DEVICES += ubnt_edgerouter
@@ -68,6 +69,7 @@ define Device/ubnt_edgerouter-lite
DEVICE_MODEL := EdgeRouter Lite
BOARD_NAME := erlite
CMDLINE := $(ERLITE_CMDLINE)
+ SUPPORTED_DEVICES += erlite
endef
TARGET_DEVICES += ubnt_edgerouter-lite