aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-22 18:07:02 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-23 08:35:59 +0100
commite3e6ec3cdafb226ba5eaab867659b08e7f0d700f (patch)
tree0bb99c2b0f724ecb16b0b3200dc6598656996dbd /target/linux
parenteb8726f9f43f9852d3ff8357278187ffa1eadf25 (diff)
downloadupstream-e3e6ec3cdafb226ba5eaab867659b08e7f0d700f.tar.gz
upstream-e3e6ec3cdafb226ba5eaab867659b08e7f0d700f.tar.bz2
upstream-e3e6ec3cdafb226ba5eaab867659b08e7f0d700f.zip
bcm63xx: limit name metadata to model name
Since there are only 16 characters available, on most cases the vendor name will fit in the metadata, but the model name won't fit. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> (cherry-picked from commit c27532742d)
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/bcm63xx/image/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index 822e26e993..f35358173c 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -84,10 +84,6 @@ endef
define rootfspad/squashfs
endef
-define Image/LimitName16
-$(shell expr substr "$(1)" 1 16)
-endef
-
define Image/FileSystemStrip
$(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
endef
@@ -96,7 +92,7 @@ define Build/cfe-bin
$(STAGING_DIR_HOST)/bin/imagetag -i $(IMAGE_KERNEL) -f $(IMAGE_ROOTFS) \
--output $@ --boardid $(CFE_BOARD_ID) --chipid $(CHIP_ID) \
--entry $(LOADER_ENTRY) --load-addr $(LOADER_ENTRY) \
- --info1 "$(call Image/LimitName16,$(DEVICE_NAME))" \
+ --info1 "$(call ModelNameLimit16,$(DEVICE_NAME))" \
--info2 "$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))" \
$(call rootfspad/$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))) \
$(CFE_EXTRAS) $(1)