aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2021-05-16 23:48:04 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2021-05-17 00:02:14 +0200
commitf9b0215e282c8d8a0e6b0f64d450fb0e77132d03 (patch)
treee678afa3fa4a2ff34ce70601c0d15aad3681f791 /target/linux
parentdee89d42ede83fbd4f554a027635ecd04dec1e23 (diff)
downloadupstream-f9b0215e282c8d8a0e6b0f64d450fb0e77132d03.tar.gz
upstream-f9b0215e282c8d8a0e6b0f64d450fb0e77132d03.tar.bz2
upstream-f9b0215e282c8d8a0e6b0f64d450fb0e77132d03.zip
ramips: fix SUPPORTED_DEVICES for ALFA Network devices
Vendor firmware expects model name without manufacturer name inside 'supported_devices' part of metadata. This allows direct upgrade to OpenWrt from vendor's GUI. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> (cherry picked from commit cf3f1f82eaa95c72b3b2620c6da15a81f8d57ba7)
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7620.mk3
-rw-r--r--target/linux/ramips/image/mt7621.mk1
-rw-r--r--target/linux/ramips/image/mt76x8.mk1
3 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index f8905ad2b7..949c09662f 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -33,6 +33,7 @@ define Device/alfa-network_ac1200rm
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := AC1200RM
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci uboot-envtools
+ SUPPORTED_DEVICES += ac1200rm
endef
TARGET_DEVICES += alfa-network_ac1200rm
@@ -43,6 +44,7 @@ define Device/alfa-network_r36m-e4g
DEVICE_MODEL := R36M-E4G
DEVICE_PACKAGES := kmod-i2c-ralink kmod-usb2 kmod-usb-ohci uboot-envtools \
uqmi
+ SUPPORTED_DEVICES += r36m-e4g
endef
TARGET_DEVICES += alfa-network_r36m-e4g
@@ -53,6 +55,7 @@ define Device/alfa-network_tube-e4g
DEVICE_MODEL := Tube-E4G
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci uboot-envtools uqmi -iwinfo \
-kmod-rt2800-soc -wpad-basic-wolfssl
+ SUPPORTED_DEVICES += tube-e4g
endef
TARGET_DEVICES += alfa-network_tube-e4g
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a55f9bceb7..a8f558326d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -111,6 +111,7 @@ define Device/alfa-network_quad-e4g
DEVICE_MODEL := Quad-E4G
DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3 uboot-envtools \
-wpad-basic-wolfssl
+ SUPPORTED_DEVICES += quad-e4g
endef
TARGET_DEVICES += alfa-network_quad-e4g
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 7ba2acacb8..315d4f8d74 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -34,6 +34,7 @@ define Device/alfa-network_awusfree1
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := AWUSFREE1
DEVICE_PACKAGES := uboot-envtools
+ SUPPORTED_DEVICES += awusfree1
endef
TARGET_DEVICES += alfa-network_awusfree1