aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>2020-04-08 21:43:36 +0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-12 13:48:31 +0200
commit027950fc781bf0e36fe9e82fd099bd4c80f8d49b (patch)
treeb8185fd51bfbe43b040519af35f19547d1499b6e /target/linux
parentad01cb514d06eb34d3d20c0025e90cfe1bf81d4c (diff)
downloadupstream-027950fc781bf0e36fe9e82fd099bd4c80f8d49b.tar.gz
upstream-027950fc781bf0e36fe9e82fd099bd4c80f8d49b.tar.bz2
upstream-027950fc781bf0e36fe9e82fd099bd4c80f8d49b.zip
ramips: use full 8MB flash on ZyXEL Keenetic
ZyXEL Keenetic has 8MB flash, but OpenWrt uses only 4MB. This commit fixes the problem. WikiDevi page [1] says that ZyXEL Keenetic has FLA1: 8 MiB, there is an article with specs [2] (in Russian). [1] https://wikidevi.wi-cat.ru/ZyXEL_Keenetic [2] https://3dnews.ru/608774/page-2.html Fixes: FS#2487 Fixes: a7cbf59e0e04 ("ramips: add new device ZyXEL Keenetic as kn") Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com> (cherry picked from commit fea232ae8feb6af780fd4fa78ebe9231778bf75a)
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/kn.dts2
-rw-r--r--target/linux/ramips/image/rt305x.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/kn.dts b/target/linux/ramips/dts/kn.dts
index 77b047c094..94f6cddf94 100644
--- a/target/linux/ramips/dts/kn.dts
+++ b/target/linux/ramips/dts/kn.dts
@@ -37,7 +37,7 @@
partition@50000 {
label = "firmware";
- reg = <0x50000 0x3b0000>;
+ reg = <0x50000 0x7b0000>;
};
};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 2d071c1ebc..0623197055 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -895,7 +895,7 @@ TARGET_DEVICES += xdxrn502j
define Device/kn
DTS := kn
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 7872k
DEVICE_TITLE := ZyXEL Keenetic
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
endef