aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJackson Ming Hu <huming2207@gmail.com>2018-01-08 13:27:28 +0800
committerMathias Kresin <dev@kresin.me>2018-01-23 23:31:09 +0100
commit21d3643828187df873118c4c2a51a48c54e0f6b1 (patch)
tree0fa594679b0a143c9fc36501fea32a47c7ec7d73 /target/linux
parenta411881a4000452ff791761c8f1d37ea6faa298a (diff)
downloadupstream-21d3643828187df873118c4c2a51a48c54e0f6b1.tar.gz
upstream-21d3643828187df873118c4c2a51a48c54e0f6b1.tar.bz2
upstream-21d3643828187df873118c4c2a51a48c54e0f6b1.zip
ramips: add support for Widora Neo 32MB flash revision
Widora has updated their Widora Neo board recently. The new model uses 32MB WSON-8 factor SPI flash instead of the original 16MB SOP-8 factor SPI flash. All the other hardware components are the same as the first revision. Detailed hardware specs listed below: CPU: MTK MT7688AN RAM: 128MB DDR2 ROM: 32MB WSON-8 factor SPI Flash (Winbond) WiFi: Built-in 802.11n 150Mbps? Ethernet: 10/100Mbps x1 Audio codec: WM8960 Other IO: USB OTG; USB Power+Serial (CP2104); 3x LEDs (Power, LAN, WiFi); 2x Keys (WPS, CPU Reset) 1x Audio In/Out 1x IPEX antenna port 1x Micro SD slot Signed-off-by: Jackson Ming Hu <huming2207@gmail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/WIDORA-NEO-32M.dts54
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
5 files changed, 66 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 53d885560b..705532753d 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -58,6 +58,7 @@ ramips_setup_interfaces()
timecloud|\
w150m|\
widora,neo-16m|\
+ widora,neo-32m|\
wnce2001|\
zbt-cpe102|\
zte-q7)
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index f08e8e1c17..dadb1bb6f6 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -285,7 +285,8 @@ get_status_led() {
zbt-we2026)
status_led="$boardname:red:power"
;;
- widora,neo-16m)
+ widora,neo-16m|\
+ widora,neo-32m)
status_led="widora:orange:wifi"
;;
wzr-agl300nh)
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 6374e3d1e7..dd7616034b 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -168,6 +168,7 @@ platform_check_image() {
whr-600d|\
whr-g300n|\
widora,neo-16m|\
+ widora,neo-32m|\
witi|\
wizfi630a|\
wl-330n|\
diff --git a/target/linux/ramips/dts/WIDORA-NEO-32M.dts b/target/linux/ramips/dts/WIDORA-NEO-32M.dts
new file mode 100644
index 0000000000..591101e3fd
--- /dev/null
+++ b/target/linux/ramips/dts/WIDORA-NEO-32M.dts
@@ -0,0 +1,54 @@
+/dts-v1/;
+
+#include "WIDORA-NEO.dtsi"
+
+/ {
+ compatible = "widora,neo-32m", "widora,neo", "mediatek,mt7628an-soc";
+ model = "Widora-NEO (32M)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <31>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x1fb0000>;
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 6c0102fc92..f58a2208c1 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -224,6 +224,14 @@ define Device/widora_neo-16m
endef
TARGET_DEVICES += widora_neo-16m
+define Device/widora_neo-32m
+ DTS := WIDORA-NEO-32M
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := Widora-NEO (32M)
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += widora_neo-32m
+
define Device/wrtnode2p
DTS := WRTNODE2P
IMAGE_SIZE := $(ralink_default_fw_size_16M)