aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-06-13 13:48:27 +0200
committerPetr Štetiar <ynezz@true.cz>2019-06-18 16:08:55 +0200
commitf342ffd300da48aa352c51bd65afebf6419b2228 (patch)
tree429e9df75ce8460af4b8598387d0d348568f0934 /target/linux
parent9b8d0f14f3027df5cb1699e1113bddf2344f14f5 (diff)
downloadupstream-f342ffd300da48aa352c51bd65afebf6419b2228.tar.gz
upstream-f342ffd300da48aa352c51bd65afebf6419b2228.tar.bz2
upstream-f342ffd300da48aa352c51bd65afebf6419b2228.zip
treewide: kernel: bump some targets to 4.19
Lets bump kernel to 4.19 on targets which were run tested or got ACKed so we've enough time to make it ready for next release: armvirt/32 (runtested in qemu) armvirt/64 (runtested in qemu) ath79/generic (runtested on Carambola2) gemini/generic (runtested on DIR-685, DNS-313, SQ201, SL93512R) imx6/generic (runtested on Apalis) ipq40xx/generic (runtested on nbg6617) malta/be64 (runtested in qemu) malta/be (runtested in qemu) malta/le (runtested in qemu) malta/le64 (runtested in qemu) mpc85xx/generic (runtested on TL-WDR4900) mpc85xx/p2020 (runtested on P2020RDB) mvebu/cortexa53 mvebu/cortexa72 mvebu/cortexa10 octeon/generic (runtested on EdgeRouter Lite) sunxi/cortexa53 (build tested only) sunxi/cortexa7 (runtested on Lime2-K) sunxi/cortexa8 (build tested only) tegra/generic x86/64 (runtested in qemu) Acked-by: Zoltan HERPAI <wigyori@uid0.hu> [sunxi] Tested-by: Linus Walleij <linus.walleij@linaro.org> [gemini] Tested-by: Tomasz Maciej Nowak <tomek_n@o2.pl> [mvebu, tegra] Tested-by: Daniel Engberg <daniel.engberg.lists@pyret.net> [octeon] Tested-by: Pawel Dembicki <paweldembicki@gmail.com> [mpc85xx/generic mpc85xx/p2020] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/armvirt/Makefile2
-rw-r--r--target/linux/ath79/Makefile3
-rw-r--r--target/linux/gemini/Makefile3
-rw-r--r--target/linux/imx6/Makefile3
-rw-r--r--target/linux/ipq40xx/Makefile6
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/mpc85xx/Makefile3
-rw-r--r--target/linux/mvebu/Makefile3
-rw-r--r--target/linux/octeon/Makefile3
-rw-r--r--target/linux/sunxi/Makefile3
-rw-r--r--target/linux/tegra/Makefile3
-rw-r--r--target/linux/x86/Makefile3
12 files changed, 13 insertions, 24 deletions
diff --git a/target/linux/armvirt/Makefile b/target/linux/armvirt/Makefile
index 107f8607c3..9a67ab66a4 100644
--- a/target/linux/armvirt/Makefile
+++ b/target/linux/armvirt/Makefile
@@ -13,7 +13,7 @@ FEATURES+=cpiogz ext4 ramdisk squashfs targz
MAINTAINER:=Florian Fainelli <f.fainelli@gmail.com>, \
Yousong Zhou <yszhou4tech@gmail.com>
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ath79/Makefile b/target/linux/ath79/Makefile
index 0ccc0bed1c..cfdf8c87e5 100644
--- a/target/linux/ath79/Makefile
+++ b/target/linux/ath79/Makefile
@@ -8,8 +8,7 @@ SUBTARGETS:=generic nand tiny
FEATURES:=ramdisk
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index 867e284714..3afc643023 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -13,8 +13,7 @@ FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
CPU_TYPE:=fa526
MAINTAINER:=Roman Yeryomin <roman@advem.lv>
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
define Target/Description
Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index 457e767c05..ac4300f7eb 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -14,8 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=neon
MAINTAINER:=Luka Perkov <luka@openwrt.org>
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
index 2785b73ed1..9b78d1f1bf 100644
--- a/target/linux/ipq40xx/Makefile
+++ b/target/linux/ipq40xx/Makefile
@@ -8,15 +8,13 @@ CPU_TYPE:=cortex-a7
CPU_SUBTYPE:=neon-vfpv4
MAINTAINER:=John Crispin <john@phrozen.org>
-# TODO: drop kmod-usb-dwc3-of-simple when migrating to 4.19
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
KERNELNAME:=zImage Image dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
- kmod-usb-dwc3-of-simple \
+ kmod-usb-dwc3-qcom \
kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
kmod-ath10k-ct wpad-basic \
kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index c71f34d109..435c1b6568 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -14,7 +14,7 @@ INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
FEATURES:=ramdisk
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 9db478d87b..8c407fd30c 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -14,8 +14,7 @@ FEATURES:=squashfs ramdisk
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS:=generic p1020 p2020
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
KERNELNAME:=zImage
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index f39573c002..1688065a5c 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -12,8 +12,7 @@ FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part
SUBTARGETS:=cortexa9 cortexa53 cortexa72
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER:=4.19
+KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 202ed39be7..aa73b0e5c0 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -13,8 +13,7 @@ FEATURES:=squashfs ramdisk pci usb
CPU_TYPE:=octeonplus
MAINTAINER:=John Crispin <john@phrozen.org>
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
define Target/Description
Build firmware images for Cavium Networks Octeon-based boards.
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
index aae7df1b44..cd1bf30e84 100644
--- a/target/linux/sunxi/Makefile
+++ b/target/linux/sunxi/Makefile
@@ -14,8 +14,7 @@ FEATURES:=fpu usb ext4 display rtc squashfs
SUBTARGETS:=cortexa8 cortexa7 cortexa53
MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
KERNELNAME:=zImage dtbs
# A10: Cortex-A8
diff --git a/target/linux/tegra/Makefile b/target/linux/tegra/Makefile
index 8a611e29ab..db58bf53d1 100644
--- a/target/linux/tegra/Makefile
+++ b/target/linux/tegra/Makefile
@@ -14,8 +14,7 @@ CPU_TYPE := cortex-a9
CPU_SUBTYPE := vfpv3
MAINTAINER := Tomasz Maciej Nowak <tomek_n@o2.pl>
-KERNEL_PATCHVER := 4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER := 4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 509ccb47a2..caa2e0b07a 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -13,8 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
SUBTARGETS:=generic legacy geode 64
MAINTAINER:=Felix Fietkau <nbd@nbd.name>
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER:=4.19
+KERNEL_PATCHVER:=4.19
KERNELNAME:=bzImage