aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-04-26 20:04:48 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-04-26 20:40:07 +0200
commitd168c2cf81ab4218df4c9b43e4483b6340bcfc9d (patch)
tree56541639d32365ce065c6ad376fd8822468ff450 /target/linux
parent746c590882b96d5ed4d4115e4bdab4c838af7806 (diff)
downloadupstream-d168c2cf81ab4218df4c9b43e4483b6340bcfc9d.tar.gz
upstream-d168c2cf81ab4218df4c9b43e4483b6340bcfc9d.tar.bz2
upstream-d168c2cf81ab4218df4c9b43e4483b6340bcfc9d.zip
ar71xx: Ubiquiti Airmax M: add relocate-kernel to invalidate cache
Some Ubiquiti U-boot versions, in particular the "U-Boot 1.1.4.2-s956 (Jun 10 2015 - 10:54:50)" found with AirOS 5.6, do not correctly flush the caches for the whole kernel address range after decompressing the kernel image, leading to hard to debug boot failures, depending on kernel version and configuration. As a workaround, prepend the relocate-kernels loader, which will invalidate the caches after moving the kernel to the correct load address. Reported-by: Andreas Ziegler <dev@andreas-ziegler.de> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index d5e3aa5860..07c0295504 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -52,6 +52,7 @@ define Device/ubnt-xm
DEVICE_PACKAGES += kmod-usb-ohci
UBNT_TYPE := XM
UBNT_CHIP := ar7240
+ KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma | uImage lzma
endef
define Device/ubnt-xw