aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorBirger Koblitz <mail@birger-koblitz.de>2019-06-18 18:49:41 +0200
committerPetr Štetiar <ynezz@true.cz>2019-06-20 08:48:19 +0200
commitab7f8146fdebe8e67a9154993154fdfe20ef51df (patch)
treea660b4805f45f2d64e6ab8649bbb8bbea88fefe7 /target/linux
parent88f7a29f99fb8209f6d7100d0cc0f7af6dba89cf (diff)
downloadupstream-ab7f8146fdebe8e67a9154993154fdfe20ef51df.tar.gz
upstream-ab7f8146fdebe8e67a9154993154fdfe20ef51df.tar.bz2
upstream-ab7f8146fdebe8e67a9154993154fdfe20ef51df.zip
ramips: add support for Edimax EW-7478APC
SoC: MediaTek MT7620a @ 580MHz RAM: 64M (Winbond W9751G6KB-25) FLASH: 8MB (Macronix) WiFi: SoC-integrated: MediaTek MT7620a bgn WiFi: MediaTek MT7612EN nac Switch: Mediatek MT7530W Gigabit Switch (4 x LAN, 1 x WAN) USB: Yes 1 x 2.0 (+ 1 x 2.0 unpopulated header) BTN: Reset/WPS LED: - Power (white) - Internet (blue) - Wifi (blue) - USB (blue) UART: UART is present as Pads with throughholes on the PCB. They are located in the lower right corner (GbE ports facing up) 3.3V - RX - GND - TX / 57600-8N1 3.3V is the square pad Installation ------------ Update the factory image via the web-interfaces (by default: http://edimax.setup) Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> [merge conflicts in 01_leds and mt7620.mk, dts whitespace issues] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ramips/dts/EW-7478APC.dts202
-rw-r--r--target/linux/ramips/image/mt7620.mk12
3 files changed, 216 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 658e3512ca..bccf68f8e5 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -35,7 +35,8 @@ alfa-network,ac1200rm)
set_wifi_led "$boardname:green:wlan2g" "wlan1"
;;
alfa-network,awusfree1|\
-edimax,br-6478ac-v2)
+edimax,br-6478ac-v2|\
+edimax,ew-7478apc)
set_wifi_led "$boardname:blue:wlan"
;;
edimax,ew-7476rpc|\
diff --git a/target/linux/ramips/dts/EW-7478APC.dts b/target/linux/ramips/dts/EW-7478APC.dts
new file mode 100644
index 0000000000..bd1768b34e
--- /dev/null
+++ b/target/linux/ramips/dts/EW-7478APC.dts
@@ -0,0 +1,202 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "edimax,ew-7478apc", "ralink,mt7620a-soc";
+ model = "Edimax EW-7478APC";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+
+ reset_wps {
+ label = "reset_wps";
+ gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "ew-7478apc:white:power";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ internet {
+ label = "ew-7478apc:blue:internet";
+ gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan {
+ label = "ew-7478apc:blue:wlan";
+ gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+ };
+
+ usb {
+ label = "ew-7478apc:blue:usb";
+ gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+ trigger-sources = <&ohci_port1>, <&ehci_port1>;
+ linux,default-trigger = "usbport";
+ };
+ };
+};
+
+&gpio2 {
+ status = "okay";
+
+ enable_usb_power {
+ gpio-hog;
+ line-name = "enable USB power";
+ gpios = <5 GPIO_ACTIVE_HIGH>;
+ output-high;
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "cimage";
+ reg = <0x50000 0x20000>;
+ read-only;
+ };
+
+ partition@70000 {
+ compatible = "edimax,uimage";
+ label = "firmware";
+ reg = <0x00070000 0x00790000>;
+ };
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "uartf", "nd_sd";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&ethernet {
+ status = "okay";
+ mtd-mac-address = <&factory 0x4>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&rgmii1_pins &rgmii2_pins &mdio_pins>;
+ mediatek,portmap = "wllll";
+
+ port@5 {
+ status = "okay";
+ mediatek,fixed-link = <1000 1 1 1>;
+ phy-mode = "rgmii";
+ };
+
+ mdio-bus {
+ status = "okay";
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ phy-mode = "rgmii";
+ };
+
+ phy1: ethernet-phy@1 {
+ reg = <1>;
+ phy-mode = "rgmii";
+ };
+
+ phy2: ethernet-phy@2 {
+ reg = <2>;
+ phy-mode = "rgmii";
+ };
+
+ phy3: ethernet-phy@3 {
+ reg = <3>;
+ phy-mode = "rgmii";
+ };
+
+ phy4: ethernet-phy@4 {
+ reg = <4>;
+ phy-mode = "rgmii";
+ };
+
+ phy1f: ethernet-phy@1f {
+ reg = <0x1f>;
+ phy-mode = "rgmii";
+ };
+ };
+};
+
+&gsw {
+ mediatek,port4 = "gmac";
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ mediatek,2ghz = <0>;
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 721cd7f43d..077834edc8 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -642,6 +642,18 @@ define Device/edimax_ew-7478ac
endef
TARGET_DEVICES += edimax_ew-7478ac
+define Device/edimax_ew-7478apc
+ DTS := EW-7478APC
+ DEVICE_TITLE := Edimax EW-7478APC
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7744k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN75 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += edimax_ew-7478apc
+
define Device/tplink_c2-v1
$(Device/Archer)
DTS := ArcherC2-v1