aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFilip Moc <lede@moc6.cz>2017-05-25 21:51:37 +0200
committerJohn Crispin <john@phrozen.org>2017-05-27 07:54:21 +0200
commita639cbfd00a47dc55b1e4cd47897fa0a3150d0e9 (patch)
tree7eb80a6f76b8b0cc33639c50886aef8dfdb7be4c /target/linux
parentb76248dd96f51594fd4894b5721753ce69456a00 (diff)
downloadupstream-a639cbfd00a47dc55b1e4cd47897fa0a3150d0e9.tar.gz
upstream-a639cbfd00a47dc55b1e4cd47897fa0a3150d0e9.tar.bz2
upstream-a639cbfd00a47dc55b1e4cd47897fa0a3150d0e9.zip
ar71xx: Add support for TP-Link MR6400
You can flash via tftp recovery (serve factory image as /mr6400_tp_recovery.bin on 192.168.0.66/24, connect to any ethernet port and power on device while holding the reset button). Flashing via OEM web interface does not work. Hardware Specification (v1.0 EU): - SoC: QCA9531 - Flash: Winbond W25Q64FV (8MiB) - RAM: EtronTech EM6AB160TSE-5G (64MiB) - Wireless: SoC platform only (2.4GHz b/g/n, 2x internal antenna) - Ethernet: 2NIC (3x100M + 1x100M) - WWAN: TP-LINK LTE MODULE (2x external detachable antenna) - Power: DC 12V 1A Signed-off-by: Filip Moc <lede@moc6.cz>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds6
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr6400.c151
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/tp-link.mk10
-rw-r--r--target/linux/ar71xx/mikrotik/config-default1
-rw-r--r--target/linux/ar71xx/nand/config-default1
13 files changed, 197 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 2f3e5efd57..520a5cdb05 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -603,6 +603,12 @@ tl-wr941nd-v5)
;;
esac
;;
+tl-mr6400)
+ ucidef_set_led_netdev "lan" "LAN" "tp-link:white:lan" "eth0"
+ ucidef_set_led_netdev "wan" "WAN" "tp-link:white:wan" "eth1"
+ ucidef_set_led_netdev "4g" "4G" "tp-link:white:4g" "usb0"
+ ucidef_set_led_wlan "wlan" "WLAN" "tp-link:white:wlan" "phy0tpt"
+ ;;
tl-wa7210n-v2)
ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index 2737129eb6..6f72fc73f7 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -311,6 +311,11 @@ ar71xx_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "1:lan:1" "2:lan:2" "3:lan:3" "4:lan:4"
;;
+ tl-mr6400)
+ ucidef_set_interfaces_lan_wan "eth0.1 eth1" "usb0"
+ ucidef_add_switch "switch0" \
+ "0@eth0" "1:lan" "2:lan" "3:lan"
+ ;;
dir-825-b1|\
nbg460n_550n_550nh|\
tew-673gru|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 9cad8995db..7a2cf927ff 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -366,6 +366,9 @@ get_status_led() {
tl-wa860re)
status_led="tp-link:green:power"
;;
+ tl-mr6400)
+ status_led="tp-link:white:power"
+ ;;
tl-mr3220|\
tl-mr3220-v2|\
tl-mr3420|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index a751c64a3a..b3de55d274 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -309,6 +309,9 @@ tplink_board_detect() {
"49000002")
model="TP-Link TL-WDR4900"
;;
+ "640000"*)
+ model="TP-Link TL-MR6400"
+ ;;
"65000002")
model="TP-Link TL-WDR6500"
;;
@@ -1016,6 +1019,9 @@ ar71xx_board_detect() {
*"TL-MR3420 v2")
name="tl-mr3420-v2"
;;
+ *TL-MR6400)
+ name="tl-mr6400"
+ ;;
*"TL-WA701ND v2")
name="tl-wa701nd-v2"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index e246f35add..c70351c1f3 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -398,6 +398,7 @@ platform_check_image() {
tl-mr3220|\
tl-mr3420-v2|\
tl-mr3420|\
+ tl-mr6400|\
tl-wa701nd-v2|\
tl-wa7210n-v2|\
tl-wa750re|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index 0a375862ba..298b3ebcbb 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -174,6 +174,7 @@ CONFIG_ATH79_MACH_TL_MR11U=y
CONFIG_ATH79_MACH_TL_MR13U=y
CONFIG_ATH79_MACH_TL_MR3020=y
CONFIG_ATH79_MACH_TL_MR3X20=y
+CONFIG_ATH79_MACH_TL_MR6400=y
CONFIG_ATH79_MACH_TL_WA701ND_V2=y
CONFIG_ATH79_MACH_TL_WA7210N_V2=y
CONFIG_ATH79_MACH_TL_WA801ND_V3=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 9030954c27..813d01a569 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1417,6 +1417,16 @@ config ATH79_MACH_TL_MR3X20
select ATH79_DEV_M25P80
select ATH79_DEV_USB
+config ATH79_MACH_TL_MR6400
+ bool "TP-LINK TL-MR6400 support"
+ select SOC_QCA953X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_TL_WAX50RE
bool "TP-LINK TL-WA750/850RE support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 2868adcaef..bc3f6819be 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -179,6 +179,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mach-tl-mr11u.o
obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mach-tl-mr13u.o
obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
+obj-$(CONFIG_ATH79_MACH_TL_MR6400) += mach-tl-mr6400.o
obj-$(CONFIG_ATH79_MACH_TL_WA701ND_V2) += mach-tl-wa701nd-v2.o
obj-$(CONFIG_ATH79_MACH_TL_WA7210N_V2) += mach-tl-wa7210n-v2.o
obj-$(CONFIG_ATH79_MACH_TL_WA801ND_V3) += mach-tl-wa801nd-v3.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr6400.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr6400.c
new file mode 100644
index 0000000000..be49c89cab
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr6400.c
@@ -0,0 +1,151 @@
+/*
+ * TP-LINK TL-MR6400 board support
+ *
+ * Copyright (C) 2017 Filip Moc <lede@moc6.cz>
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ * * The name of the author may not be used to endorse or promote products
+ * derived from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+ * WARRANTIES, ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+ * DAMAGES ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TL_MR6400_GPIO_LTE_POWER 4
+#define TL_MR6400_GPIO_BTN_RESET 12 /* SW2 */
+#define TL_MR6400_GPIO_BTN_RFKILL 14 /* SW3 */
+#define TL_MR6400_GPIO_LED_WAN 0 /* D12 */
+#define TL_MR6400_GPIO_LED_4G 1 /* D11 */
+#define TL_MR6400_GPIO_LED_WPS 3 /* D5 */
+#define TL_MR6400_GPIO_LED_WLAN 11 /* D3 */
+#define TL_MR6400_GPIO_LED_POWER 13 /* D2 */
+#define TL_MR6400_GPIO_LED_LAN 16 /* D4 */
+
+#define TL_MR6400_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TL_MR6400_KEYS_DEBOUNCE_INTERVAL (3 * TL_MR6400_KEYS_POLL_INTERVAL)
+
+#define TL_MR6400_WMAC_CALDATA_OFFSET 0x1000
+
+static const char *tl_mr6400_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data tl_mr6400_flash_data = {
+ .part_probes = tl_mr6400_part_probes,
+ .type = "w25q64",
+};
+
+static struct gpio_led tl_mr6400_leds_gpio[] __initdata = {
+ {
+ .name = "tp-link:white:wan",
+ .gpio = TL_MR6400_GPIO_LED_WAN,
+ .active_low = 0,
+ },
+ {
+ .name = "tp-link:white:4g",
+ .gpio = TL_MR6400_GPIO_LED_4G,
+ .active_low = 0,
+ },
+ {
+ .name = "tp-link:white:wps",
+ .gpio = TL_MR6400_GPIO_LED_WPS,
+ .active_low = 0,
+ },
+ {
+ .name = "tp-link:white:wlan",
+ .gpio = TL_MR6400_GPIO_LED_WLAN,
+ .active_low = 0,
+ },
+ {
+ .name = "tp-link:white:power",
+ .gpio = TL_MR6400_GPIO_LED_POWER,
+ .active_low = 0,
+ },
+ {
+ .name = "tp-link:white:lan",
+ .gpio = TL_MR6400_GPIO_LED_LAN,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button tl_mr6400_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TL_MR6400_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_MR6400_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "rfkill",
+ .type = EV_KEY,
+ .code = KEY_RFKILL,
+ .debounce_interval = TL_MR6400_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_MR6400_GPIO_BTN_RFKILL,
+ .active_low = 1,
+ },
+};
+
+static void __init tl_mr6400_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(&tl_mr6400_flash_data);
+
+ ath79_register_mdio(0, 0x0);
+
+ /* LAN1, LAN2, LAN3 */
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask |= BIT(0);
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+ ath79_register_eth(1);
+
+ /* LAN4 / WAN */
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+ ath79_register_eth(0);
+
+ ath79_register_wmac(art + TL_MR6400_WMAC_CALDATA_OFFSET, mac);
+
+ ath79_register_leds_gpio(-1,
+ ARRAY_SIZE(tl_mr6400_leds_gpio),
+ tl_mr6400_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1,
+ TL_MR6400_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tl_mr6400_gpio_keys),
+ tl_mr6400_gpio_keys);
+
+ gpio_request_one(TL_MR6400_GPIO_LTE_POWER,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED | GPIOF_ACTIVE_LOW,
+ "LTE power");
+ ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_MR6400, "TL-MR6400", "TP-LINK TL-MR6400",
+ tl_mr6400_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 18033acd12..841badc14f 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -213,6 +213,7 @@ enum ath79_mach_type {
ATH79_MACH_TL_MR3220_V2, /* TP-LINK TL-MR3220 v2 */
ATH79_MACH_TL_MR3420, /* TP-LINK TL-MR3420 */
ATH79_MACH_TL_MR3420_V2, /* TP-LINK TL-MR3420 v2 */
+ ATH79_MACH_TL_MR6400, /* TP-LINK TL-MR6400 */
ATH79_MACH_TL_WA701ND_V2, /* TP-LINK TL-WA701ND v2 */
ATH79_MACH_TL_WA7210N_V2, /* TP-LINK TL-WA7210N v2 */
ATH79_MACH_TL_WA750RE, /* TP-LINK TL-WA750RE */
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 6ddf05239d..f27ceec3e9 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -452,6 +452,16 @@ define Device/tl-mr3420-v2
endef
TARGET_DEVICES += tl-mr3020-v1 tl-mr3040-v1 tl-mr3040-v2 tl-mr3220-v1 tl-mr3220-v2 tl-mr3420-v1 tl-mr3420-v2
+define Device/tl-mr6400-v1
+ $(Device/tplink-8mlzma)
+ DEVICE_TITLE := TP-LINK TL-MR6400 v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb
+ BOARDNAME := TL-MR6400
+ DEVICE_PROFILE := TLMR6400
+ TPLINK_HWID := 0x64000001
+endef
+TARGET_DEVICES += tl-mr6400-v1
+
define Device/tl-wpa8630-v1
$(Device/tplink-8mlzma)
DEVICE_TITLE := TP-LINK TL-WPA8630 v1
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index ecaa6e53d0..216ffa27cb 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -137,6 +137,7 @@ CONFIG_ATH79_MACH_RBSXTLITE=y
# CONFIG_ATH79_MACH_TL_MR13U is not set
# CONFIG_ATH79_MACH_TL_MR3020 is not set
# CONFIG_ATH79_MACH_TL_MR3X20 is not set
+# CONFIG_ATH79_MACH_TL_MR6400 is not set
# CONFIG_ATH79_MACH_TL_WA701ND_V2 is not set
# CONFIG_ATH79_MACH_TL_WA7210N_V2 is not set
# CONFIG_ATH79_MACH_TL_WA801ND_V3 is not set
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
index f744da80c1..8c7d445282 100644
--- a/target/linux/ar71xx/nand/config-default
+++ b/target/linux/ar71xx/nand/config-default
@@ -126,6 +126,7 @@ CONFIG_ATH79_MACH_RAMBUTAN=y
# CONFIG_ATH79_MACH_TL_MR13U is not set
# CONFIG_ATH79_MACH_TL_MR3020 is not set
# CONFIG_ATH79_MACH_TL_MR3X20 is not set
+# CONFIG_ATH79_MACH_TL_MR6400 is not set
# CONFIG_ATH79_MACH_TL_WA701ND_V2 is not set
# CONFIG_ATH79_MACH_TL_WA7210N_V2 is not set
# CONFIG_ATH79_MACH_TL_WA801ND_V3 is not set