aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-10-15 23:41:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-10-15 23:41:00 +0000
commit994345cd38c3aaf0e2a0fc232be446ee12320442 (patch)
treef44aa514cf2046af6c6835b0760f0ae9c1045678 /target/linux
parent00818780b417dc2a6217daaca6cf27dbf1c00894 (diff)
downloadupstream-994345cd38c3aaf0e2a0fc232be446ee12320442.tar.gz
upstream-994345cd38c3aaf0e2a0fc232be446ee12320442.tar.bz2
upstream-994345cd38c3aaf0e2a0fc232be446ee12320442.zip
Drop changes to mm/fault.c prevents from seeing kernel oops while restarting the board automatically
SVN-Revision: 5141
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/rdc-2.6/patches/000-rdc_fixes.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/rdc-2.6/patches/000-rdc_fixes.patch b/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
index 4a75f5fca1..5e3878d08f 100644
--- a/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
+++ b/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
@@ -835,27 +835,3 @@ diff -urN linux-2.6.17/arch/i386/Makefile linux-2.6.17.new/arch/i386/Makefile
# default subarch .h files
mflags-y += -Iinclude/asm-i386/mach-default
-diff -urN linux-2.6.17/arch/i386/mm/fault.c linux-2.6.17.new/arch/i386/mm/fault.c
---- linux-2.6.17/arch/i386/mm/fault.c 2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/arch/i386/mm/fault.c 2006-10-07 22:24:15.000000000 +0200
-@@ -551,6 +551,7 @@
- tsk->thread.cr2 = address;
- tsk->thread.trap_no = 14;
- tsk->thread.error_code = error_code;
-+ machine_restart(NULL); /* Added for RDC */
- die("Oops", regs, error_code);
- bust_spinlocks(0);
- do_exit(SIGKILL);
-@@ -566,6 +567,12 @@
- down_read(&mm->mmap_sem);
- goto survive;
- }
-+ /* RDC : Forcing processes to be niced */
-+ if (tsk->prio < 0) {
-+ printk("VM: niced process %s\n", tsk->comm);
-+ yield();
-+ goto survive;
-+ }
- printk("VM: killing process %s\n", tsk->comm);
- if (error_code & 4)
- do_exit(SIGKILL);