aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-07-30 11:08:03 +0200
committerMathias Kresin <dev@kresin.me>2017-08-03 00:11:25 +0200
commit419fa7a15f04c03788de956d6c8eb1ade2346be9 (patch)
tree6669d201eaf3077cb45f5918911f96e3cb8f7913 /target/linux
parentb82ac84229eb322df97ca7d29edd780b303915a6 (diff)
downloadupstream-419fa7a15f04c03788de956d6c8eb1ade2346be9.tar.gz
upstream-419fa7a15f04c03788de956d6c8eb1ade2346be9.tar.bz2
upstream-419fa7a15f04c03788de956d6c8eb1ade2346be9.zip
ramips: cleanup AsiaRF AWM002 eval board support
Cleanup the dtsi files and remove one layer of dtsi. Set the size of the firmware partition to a value matching the flash size from the board (variant) name. Remove the usb led trigger. There is neither a default config for the usb led trigger nor a LED for usb activity indication. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/AWM002-4M.dtsi10
-rw-r--r--target/linux/ramips/dts/AWM002-8M.dtsi10
-rw-r--r--target/linux/ramips/dts/AWM002-EVB-4M.dts66
-rw-r--r--target/linux/ramips/dts/AWM002-EVB-8M.dts66
-rw-r--r--target/linux/ramips/dts/AWM002-EVB.dtsi74
-rw-r--r--target/linux/ramips/dts/AWM002.dtsi62
-rw-r--r--target/linux/ramips/image/rt305x.mk4
7 files changed, 130 insertions, 162 deletions
diff --git a/target/linux/ramips/dts/AWM002-4M.dtsi b/target/linux/ramips/dts/AWM002-4M.dtsi
deleted file mode 100644
index 3ea20e6a95..0000000000
--- a/target/linux/ramips/dts/AWM002-4M.dtsi
+++ /dev/null
@@ -1,10 +0,0 @@
-#include "AWM002.dtsi"
-
-/ {
- compatible = "AWM002", "ralink,rt5350-soc";
- model = "AsiaRF AWM002";
-};
-
-&m25p80 {
- compatible = "jedec,spi-nor";
-};
diff --git a/target/linux/ramips/dts/AWM002-8M.dtsi b/target/linux/ramips/dts/AWM002-8M.dtsi
deleted file mode 100644
index 3ea20e6a95..0000000000
--- a/target/linux/ramips/dts/AWM002-8M.dtsi
+++ /dev/null
@@ -1,10 +0,0 @@
-#include "AWM002.dtsi"
-
-/ {
- compatible = "AWM002", "ralink,rt5350-soc";
- model = "AsiaRF AWM002";
-};
-
-&m25p80 {
- compatible = "jedec,spi-nor";
-};
diff --git a/target/linux/ramips/dts/AWM002-EVB-4M.dts b/target/linux/ramips/dts/AWM002-EVB-4M.dts
index a8afab80e4..b1394405f0 100644
--- a/target/linux/ramips/dts/AWM002-EVB-4M.dts
+++ b/target/linux/ramips/dts/AWM002-EVB-4M.dts
@@ -1,55 +1,43 @@
/dts-v1/;
-#include "AWM002-4M.dtsi"
-
-#include <dt-bindings/input/input.h>
+#include "AWM002-EVB.dtsi"
/ {
+ compatible = "asiarf,awm002-evb-4m", "ralink,rt5350-soc";
model = "AsiaRF AWM002 EVB (4M)";
+};
- gpio-leds {
- compatible = "gpio-leds";
-
- tx {
- label = "awm002-evb:green:tx";
- gpios = <&gpio0 15 1>;
- };
+&spi0 {
+ status = "okay";
- rx {
- label = "awm002-evb:green:rx";
- gpios = <&gpio0 16 1>;
+ m25p80: m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ reg = <0>;
+ compatible = "jedec,spi-nor";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
};
- wps {
- label = "awm002-evb:green:wps";
- gpios = <&gpio0 21 1>;
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
};
- };
- gpio-keys-polled {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset_wps {
- label = "reset_wps";
- gpios = <&gpio0 0 1>;
- linux,code = <KEY_RESTART>;
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
};
- mode {
- label = "mode";
- gpios = <&gpio0 20 1>;
- linux,code = <BTN_0>;
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
};
};
};
-
-&ethernet {
- mtd-mac-address = <&factory 0x28>;
-};
-
-&wmac {
- ralink,mtd-eeprom = <&factory 0>;
-};
diff --git a/target/linux/ramips/dts/AWM002-EVB-8M.dts b/target/linux/ramips/dts/AWM002-EVB-8M.dts
index 19b78aab02..52d5ed7f91 100644
--- a/target/linux/ramips/dts/AWM002-EVB-8M.dts
+++ b/target/linux/ramips/dts/AWM002-EVB-8M.dts
@@ -1,55 +1,43 @@
/dts-v1/;
-#include "AWM002-8M.dtsi"
-
-#include <dt-bindings/input/input.h>
+#include "AWM002-EVB.dtsi"
/ {
+ compatible = "asiarf,awm002-evb-8m", "ralink,rt5350-soc";
model = "AsiaRF AWM002 EVB (8M)";
+};
- gpio-leds {
- compatible = "gpio-leds";
-
- tx {
- label = "awm002-evb:green:tx";
- gpios = <&gpio0 15 1>;
- };
+&spi0 {
+ status = "okay";
- rx {
- label = "awm002-evb:green:rx";
- gpios = <&gpio0 16 1>;
+ m25p80: m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ reg = <0>;
+ compatible = "jedec,spi-nor";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
};
- wps {
- label = "awm002-evb:green:wps";
- gpios = <&gpio0 21 1>;
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
};
- };
- gpio-keys-polled {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset_wps {
- label = "reset_wps";
- gpios = <&gpio0 0 1>;
- linux,code = <KEY_RESTART>;
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
};
- mode {
- label = "mode";
- gpios = <&gpio0 20 1>;
- linux,code = <BTN_0>;
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
};
};
};
-
-&ethernet {
- mtd-mac-address = <&factory 0x28>;
-};
-
-&wmac {
- ralink,mtd-eeprom = <&factory 0>;
-};
diff --git a/target/linux/ramips/dts/AWM002-EVB.dtsi b/target/linux/ramips/dts/AWM002-EVB.dtsi
new file mode 100644
index 0000000000..0e82436027
--- /dev/null
+++ b/target/linux/ramips/dts/AWM002-EVB.dtsi
@@ -0,0 +1,74 @@
+#include "rt5350.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "asiarf,awm002-evb", "ralink,rt5350-soc";
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ tx {
+ label = "awm002-evb:green:tx";
+ gpios = <&gpio0 15 1>;
+ };
+
+ rx {
+ label = "awm002-evb:green:rx";
+ gpios = <&gpio0 16 1>;
+ };
+
+ wps {
+ label = "awm002-evb:green:wps";
+ gpios = <&gpio0 21 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset_wps {
+ label = "reset_wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ mode {
+ label = "mode";
+ gpios = <&gpio0 20 1>;
+ linux,code = <BTN_0>;
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&esw {
+ mediatek,portmap = <0x3f>;
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
diff --git a/target/linux/ramips/dts/AWM002.dtsi b/target/linux/ramips/dts/AWM002.dtsi
deleted file mode 100644
index 00a4ddbcf1..0000000000
--- a/target/linux/ramips/dts/AWM002.dtsi
+++ /dev/null
@@ -1,62 +0,0 @@
-#include "rt5350.dtsi"
-
-/ {
- compatible = "AWM002", "ralink,rt5350-soc";
- model = "AsiaRF AWM002";
-};
-
-&spi0 {
- status = "okay";
-
- m25p80: m25p80@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- reg = <0>;
- compatible = "jedec,spi-nor";
- spi-max-frequency = <10000000>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "u-boot-env";
- reg = <0x30000 0x10000>;
- read-only;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0x1fb0000>;
- };
- };
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "i2c", "jtag";
- ralink,function = "gpio";
- };
- };
-};
-
-&esw {
- mediatek,portmap = <0x3f>;
-};
-
-&ehci {
- status = "okay";
-};
-
-&ohci {
- status = "okay";
-};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 013f6c1178..4e82eb48a9 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -137,7 +137,7 @@ define Device/awm002-evb-4M
DTS := AWM002-EVB-4M
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := AsiaRF AWM002-EVB (4M)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
kmod-i2c-core kmod-i2c-gpio
endef
TARGET_DEVICES += awm002-evb-4M
@@ -145,7 +145,7 @@ TARGET_DEVICES += awm002-evb-4M
define Device/awm002-evb-8M
DTS := AWM002-EVB-8M
DEVICE_TITLE := AsiaRF AWM002-EVB (8M)/AsiaRF AWM003 EVB
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
kmod-i2c-core kmod-i2c-gpio
endef
TARGET_DEVICES += awm002-evb-8M