aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-12-15 15:57:49 +0100
committerMathias Kresin <dev@kresin.me>2017-12-23 15:35:52 +0100
commit39e9bfb18199b046bd3b613002112e4e6dd53658 (patch)
treece67800be1fe11212ebe26592907817008b37aa0 /target/linux
parent8ca650b8ce22fe2175cf15cfdd0e25206dd77481 (diff)
downloadupstream-39e9bfb18199b046bd3b613002112e4e6dd53658.tar.gz
upstream-39e9bfb18199b046bd3b613002112e4e6dd53658.tar.bz2
upstream-39e9bfb18199b046bd3b613002112e4e6dd53658.zip
ramips: add support for TP-Link TL-MR3420 v5
TP-Link TL-MR3420 v5 are simple N300 router with 5-port FE switch and non-detachable antennas. Its very similar to TP-Link TL-WR841N V13. Specification: - MT7628N/N (580 MHz) - 64 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz - 5x 10/100 Mbps Ethernet - 2x external, non-detachable antennas - USB 2.0 Port - UART (J1) header on PCB (115200 8n1) - 8x LED, 2x button, power input switch Flash instruction: The only way to flash LEDE image in mr3420v5 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.225/24 and tftp server. 2. Rename "lede-ramips-mt7628-tplink_tl-mr3420-v5-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds6
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/TL-MR3420V5.dts86
-rw-r--r--target/linux/ramips/image/mt76x8.mk14
6 files changed, 109 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index a5c51c7c88..a1c0c0e690 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -381,6 +381,12 @@ tl-wr841n-v13)
ucidef_set_led_switch "lan4" "lan4" "$boardname:green:lan4" "switch0" "0x10"
ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
;;
+tplink,tl-mr3420-v5)
+ set_usb_led "$boardname:green:usb"
+ set_wifi_led "$boardname:green:wlan"
+ ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
+ ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
+ ;;
u25awf-h1)
set_wifi_led "u25awf:red:wifi"
ucidef_set_led_netdev "eth" "eth" "u25awf:green:lan" "eth0"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 5a64bb727a..b8116c773b 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -173,6 +173,7 @@ ramips_setup_interfaces()
mzk-wdpr|\
rb750gr3|\
rt-n14u|\
+ tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
tl-wr841n-v13|\
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index e7b49a5039..6ad22f56c8 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -37,6 +37,7 @@ get_status_led() {
nbg-419n2|\
pwh2004|\
r6220|\
+ tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
tl-wr841n-v13|\
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 68b47eeba0..8160f5d388 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -240,6 +240,7 @@ platform_check_image() {
c20i|\
c50|\
mr200|\
+ tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
tl-wr841n-v13)
diff --git a/target/linux/ramips/dts/TL-MR3420V5.dts b/target/linux/ramips/dts/TL-MR3420V5.dts
new file mode 100644
index 0000000000..fdb09dcd6e
--- /dev/null
+++ b/target/linux/ramips/dts/TL-MR3420V5.dts
@@ -0,0 +1,86 @@
+/dts-v1/;
+
+#include "TL-WR84XN.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "tplink,tl-mr3420-v5", "mediatek,mt7628an-soc";
+ model = "TP-Link TL-MR3420 v5";
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RFKILL>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ lan {
+ label = "tl-mr3420-v5:green:lan";
+ gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
+ };
+
+ power {
+ label = "tl-mr3420-v5:green:power";
+ gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+ };
+
+ usb {
+ label = "tl-mr3420-v5:green:usb";
+ gpios = <&gpio0 3 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "tl-mr3420-v5:green:wan";
+ gpios = <&gpio0 5 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_amber {
+ label = "tl-mr3420-v5:amber:wan";
+ gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan {
+ label = "tl-mr3420-v5:green:wlan";
+ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "tl-mr3420-v5:green:wps";
+ gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "i2s", "p2led_an", "refclk", "uart1", "wdt", "wled_an";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index e11a89bb55..8bbbcf6ad9 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -139,6 +139,20 @@ define Device/tl-wr841n-v13
endef
TARGET_DEVICES += tl-wr841n-v13
+define Device/tplink_tl-mr3420-v5
+ $(Device/tplink)
+ DTS := TL-MR3420V5
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-MR3420 v5
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x34200005
+ TPLINK_HWREV := 0x5
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_tl-mr3420-v5
+
define Device/u7628-01-128M-16M
DTS := U7628-01-128M-16M
IMAGE_SIZE := 16064k