aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-11-12 01:26:44 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 15:37:37 +0100
commit0375c076b67cda9dc1b758b87ab1b79fd2403d94 (patch)
tree7ff5091a44f06edd3d398831c1718ec34e6edc38 /target/linux
parent69fff339e965d508b4fc12ffdc2a170efe9c98b1 (diff)
downloadupstream-0375c076b67cda9dc1b758b87ab1b79fd2403d94.tar.gz
upstream-0375c076b67cda9dc1b758b87ab1b79fd2403d94.tar.bz2
upstream-0375c076b67cda9dc1b758b87ab1b79fd2403d94.zip
ramips: add support for ZIO FREEZIO
ZIO FREEZIO is a 2.4/5GHz band AC1200 router, based on MediaTek MT7621A. Specifications: - SoC: MT7621AT - RAM: DDR3 128MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: MT7603EN - 5GHz: MT7612EN - Ethernet: 5x 10/100/1000Mbps - Switch: SoC internal - USB: 1x 3.0 - UART: - J4: 3.3V, RX, TX, GND (3.3V is the square pad) / 57600 8N1 Notes: - FREEZIO has almost the same board as WeVO W2914NS v2. - Stock firmware is based on OpenWrt BB. MAC addresses in factory partition: 0x0004: WiFi 2.4GHz (label_mac-8) 0x002e: WAN (label_mac) 0x8004: WiFi 5GHz (label_mac-4) 0xe000: LAN (label_mac+1) Installation via web interface: 1. Access web admin page and turn on "OpenWrt UI mode". 2. Flash sysupgrade image through LuCI, with the "Keep settings" option OFF. Revert to stock firmware: 1. Perform sysupgrade with stock image. Make sure to NOT preserve settings. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [rebase, use mt7621_wevo_w2914ns-v2.dtsi] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7621_zio_freezio.dts20
-rw-r--r--target/linux/ramips/image/mt7621.mk9
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/02_network6
3 files changed, 33 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/mt7621_zio_freezio.dts b/target/linux/ramips/dts/mt7621_zio_freezio.dts
new file mode 100644
index 0000000000..dce1c4bd4d
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_zio_freezio.dts
@@ -0,0 +1,20 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621_wevo_w2914ns-v2.dtsi"
+
+/ {
+ compatible = "zio,freezio", "mediatek,mt7621-soc";
+ model = "ZIO FREEZIO";
+
+ leds {
+ compatible = "gpio-leds";
+
+ usb {
+ label = "freezio:green:usb";
+ gpios = <&gpio0 27 GPIO_ACTIVE_LOW>;
+ trigger-sources = <&xhci_ehci_port1>;
+ linux,default-trigger = "usbport";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d663aa29da..0b2b74800a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -910,3 +910,12 @@ define Device/zbtlink_zbt-wg3526-32m
SUPPORTED_DEVICES += ac1200pro zbt-wg3526-32M
endef
TARGET_DEVICES += zbtlink_zbt-wg3526-32m
+
+define Device/zio_freezio
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ZIO
+ DEVICE_MODEL := FREEZIO
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += zio_freezio
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 2447ff8a8d..c9e3cbb984 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -45,7 +45,8 @@ ramips_setup_interfaces()
netgear,wndr3700-v5|\
netis,wf-2881|\
wevo,11acnas|\
- wevo,w2914ns-v2)
+ wevo,w2914ns-v2|\
+ zio,freezio)
ucidef_add_switch "switch0" \
"0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
;;
@@ -241,7 +242,8 @@ ramips_setup_macs()
wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 0x22)" 1)
;;
wevo,11acnas|\
- wevo,w2914ns-v2)
+ wevo,w2914ns-v2|\
+ zio,freezio)
wan_mac=$(mtd_get_mac_binary factory 0x2e)
label_mac=$wan_mac
;;