aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMario Schroen <m.schroen@web.de>2019-03-31 21:07:03 +0200
committerPetr Štetiar <ynezz@true.cz>2019-04-02 02:10:59 +0200
commit5ec205d7ac00de89510a6e71055d45aa57b705e1 (patch)
tree950387166b672b140d060c5c72ae47b7bc9434be /target/linux
parent99f6f2c0b8cbeb0c6ba464e080ab039984444f1f (diff)
downloadupstream-5ec205d7ac00de89510a6e71055d45aa57b705e1.tar.gz
upstream-5ec205d7ac00de89510a6e71055d45aa57b705e1.tar.bz2
upstream-5ec205d7ac00de89510a6e71055d45aa57b705e1.zip
ath79: Add support for TP-Link CPE210 v3
Specifications: * SoC: Qualcomm Atheros QCA9533 (650MHz) * RAM: 64MB * Storage: 8 MB SPI NOR * Wireless: 2.4GHz N based built into SoC 2x2 * Ethernet: 1x 100/10 Mbps, integrated into SoC, 24V POE IN Installation: Flash factory image through stock firmware WEB UI or TFTP To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP adress:192.168.0.254 Thanks to robimarko for the work inside the ar71xx tree. Thanks to adrianschmutzler for deep discussion and fixes. Signed-off-by: Mario Schroen <m.schroen@web.de> [Split into DTS/DTSI, read-only config partition in DTSI] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> [renamed dtsi filename, light subject touches] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds8
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts9
-rw-r--r--target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi125
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk13
5 files changed, 156 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 68cff4b4b0..47fac18281 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -123,6 +123,14 @@ tplink,archer-c6-v2)
ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x3C"
ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x02"
;;
+tplink,cpe210-v3)
+ ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+ ucidef_set_rssimon "wlan0" "200000" "1"
+ ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:link1" "wlan0" "1" "100"
+ ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:link2" "wlan0" "30" "100"
+ ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:link3" "wlan0" "60" "100"
+ ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "tp-link:green:link4" "wlan0" "80" "100"
+ ;;
tplink,re450-v2)
ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index a328ef36e9..1041af561e 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -19,6 +19,7 @@ ath79_setup_interfaces()
pcs,cap324|\
pisen,wmm003n|\
pqi,air-pen|\
+ tplink,cpe210-v3|\
tplink,re350k-v1|\
tplink,re450-v2|\
tplink,tl-mr10u|\
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts b/target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts
new file mode 100644
index 0000000000..cf1f728d0f
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_cpe210.dtsi"
+
+/ {
+ compatible = "tplink,cpe210-v3", "qca,qca9533";
+ model = "TP-LINK CPE210 v3";
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi b/target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi
new file mode 100644
index 0000000000..ee1f904491
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi
@@ -0,0 +1,125 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ aliases {
+ led-boot = &system;
+ led-failsafe = &system;
+ led-running = &system;
+ led-upgrade = &system;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ lan {
+ label = "tp-link:green:lan";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ link1 {
+ label = "tp-link:green:link1";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ };
+
+ link2 {
+ label = "tp-link:green:link2";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+
+ link3 {
+ label = "tp-link:green:link3";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ system: link4 {
+ label = "tp-link:green:link4";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+};
+
+&uart {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "partition-table";
+ reg = <0x020000 0x10000>;
+ read-only;
+ };
+
+ info: partition@30000 {
+ label = "product-info";
+ reg = <0x030000 0x10000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "firmware";
+ reg = <0x040000 0x780000>;
+ compatible = "tplink,firmware";
+ };
+
+ config: partition@7c0000 {
+ label = "config";
+ reg = <0x7c0000 0x30000>;
+ read-only;
+ };
+
+ ART: partition@7f0000 {
+ label = "ART";
+ reg = <0x7f0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+ phy-handle = <&swphy4>;
+ mtd-mac-address = <&info 0x8>;
+};
+
+&eth1 {
+ compatible = "syscon", "simple-mfd";
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&ART 0x1000>;
+ mtd-mac-address = <&info 0x8>;
+};
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 19a156be79..92d811f10b 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -109,6 +109,19 @@ define Device/tplink_archer-c7-v5
endef
TARGET_DEVICES += tplink_archer-c7-v5
+define Device/tplink_cpe210-v3
+ $(Device/tplink-safeloader)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 7680k
+ DEVICE_TITLE := TP-Link CPE210 v3
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE210V3
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+ SUPPORTED_DEVICES += cpe210-v3
+endef
+TARGET_DEVICES += tplink_cpe210-v3
+
define Device/tplink_re350k-v1
$(Device/tplink)
ATH_SOC := qca9558