aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2016-10-06 14:27:49 +0800
committerJohn Crispin <john@phrozen.org>2016-10-26 14:07:20 +0200
commitc5a7e2c2fb39ea32ce31e20d02a571b546531f1c (patch)
tree6e9909f8fb4f2697e3cc056ce3a1c438d379edbf /target/linux
parent9275964e1d5978756e8df699eb2b505ebfc859f6 (diff)
downloadupstream-c5a7e2c2fb39ea32ce31e20d02a571b546531f1c.tar.gz
upstream-c5a7e2c2fb39ea32ce31e20d02a571b546531f1c.tar.bz2
upstream-c5a7e2c2fb39ea32ce31e20d02a571b546531f1c.zip
ar71xx: Ignore firmware building errors of UBNT and CyberTAN devices
Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/legacy.mk14
-rw-r--r--target/linux/ar71xx/image/ubnt.mk13
2 files changed, 14 insertions, 13 deletions
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index d4f959430f..ec28fcbe77 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -659,18 +659,18 @@ endef
define Image/Build/CyberTAN
echo -n '' > $(KDIR_TMP)/empty.bin
- $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp \
+ -$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp \
-f $(KDIR_TMP)/vmlinux-$(2).uImage -F $(KDIR_TMP)/empty.bin \
- -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
- -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(5) \
+ -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1) && \
+ $(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(5) \
-i $(KDIR)/image.tmp \
-o $(call sysupname,$(1),$(2))
- $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \
- -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
- -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(5) -g \
+ -$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \
+ -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1) && \
+ $(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(5) -g \
-i $(KDIR)/image.tmp \
-o $(call factoryname,$(1),$(2))
- rm $(KDIR)/image.tmp
+ -rm $(KDIR)/image.tmp
endef
Image/Build/CyberTANGZIP/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 5a4dc82c4f..be5c397e53 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -5,7 +5,7 @@
# mkubntimage is using the kernel image direct
# routerboard creates partitions out of the ubnt header
define Build/mkubntimage
- $(STAGING_DIR_HOST)/bin/mkfwimage \
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
-k $(IMAGE_KERNEL) \
-r $@ \
@@ -15,18 +15,19 @@ endef
# all UBNT XM device expect the kernel image to have 1024k while flash, when
# booting the image, the size doesn't matter.
define Build/mkubntimage-split
- dd if=$@ of=$@.old1 bs=1024k count=1
- dd if=$@ of=$@.old2 bs=1024k skip=1
+ -[ -f $@ ] && ( \
+ dd if=$@ of=$@.old1 bs=1024k count=1; \
+ dd if=$@ of=$@.old2 bs=1024k skip=1; \
$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
-k $@.old1 \
-r $@.old2 \
- -o $@
- rm $@.old1 $@.old2
+ -o $@; \
+ rm $@.old1 $@.old2 )
endef
define Build/mkubntimage2
- $(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
+ -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
-v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
-p jffs2:0x50000:0xf60000:0:0:$@ \
-o $@.new