aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorEdmunt Pienkowsky <roed@onet.eu>2017-10-21 11:07:43 +0200
committerMathias Kresin <dev@kresin.me>2017-10-27 11:19:38 +0200
commit9786b53efb8225f5b6f21921e684b40b9febe61e (patch)
tree5e4a463bb325a1e96e5eee240ef7df865b87cd02 /target/linux
parent4425fa84dad57b6b0046b97e224d50b33f1f536b (diff)
downloadupstream-9786b53efb8225f5b6f21921e684b40b9febe61e.tar.gz
upstream-9786b53efb8225f5b6f21921e684b40b9febe61e.tar.bz2
upstream-9786b53efb8225f5b6f21921e684b40b9febe61e.zip
ramips: fix Youku-YK1 support
Remove the ephy-pins from the ethernet device tree node. The ephy-pins are useed to controll the ePHY LEDs and this board doesn't have these. Instead one of the ePHY pins is used in GPIO mode to control the WAN LED. Use the switch LED trigger to control the WAN LED. Move the power LED handling to diag.sh to show the boot status via this LED. Add the missing kernel packages for USB and microSD card reader to the default package selection. Fix the maximum image size value. The board has a 32MByte flash chip. Fixes: FS#1055 Signed-off-by: Edmunt Pienkowsky <roed@onet.eu> [make the commit message more verbose, remove GPIO pinmux for pins not used as GPIOs] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds2
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rw-r--r--target/linux/ramips/dts/YOUKU-YK1.dts3
-rw-r--r--target/linux/ramips/image/mt7620.mk3
4 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 75ab0da741..037331df96 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -461,9 +461,9 @@ zte-q7)
set_wifi_led "$board:blue:status"
;;
youku-yk1)
- ucidef_set_led_default "power" "power" "$board:blue:power" "1"
set_wifi_led "$board:blue:air"
set_usb_led "$board:blue:usb"
+ ucidef_set_led_switch "wan" "wan" "$board:blue:wan" "switch0" "0x10"
;;
esac
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 4411babbf9..3b3c455ba5 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -134,7 +134,8 @@ get_status_led() {
wl-330n3g|\
wli-tx4-ag300n|\
y1|\
- y1s)
+ y1s|\
+ youku-yk1)
status_led="$board:blue:power"
;;
db-wrt01|\
diff --git a/target/linux/ramips/dts/YOUKU-YK1.dts b/target/linux/ramips/dts/YOUKU-YK1.dts
index d4e3c905b3..8a0e0819ec 100644
--- a/target/linux/ramips/dts/YOUKU-YK1.dts
+++ b/target/linux/ramips/dts/YOUKU-YK1.dts
@@ -96,7 +96,7 @@
&pinctrl {
state_default: pinctrl0 {
default {
- ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+ ralink,group = "i2c", "rgmii1", "ephy", "wled";
ralink,function = "gpio";
};
};
@@ -104,7 +104,6 @@
&ethernet {
pinctrl-names = "default";
- pinctrl-0 = <&ephy_pins>;
mtd-mac-address = <&factory 0x4>;
mediatek,portmap = "llllw";
};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 8eac6f5752..2f3f59e4c6 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -505,8 +505,9 @@ TARGET_DEVICES += y1s
define Device/youku-yk1
DTS := YOUKU-YK1
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
DEVICE_TITLE := YOUKU YK1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += youku-yk1