aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-27 15:18:22 +0200
committerFelix Fietkau <nbd@nbd.name>2017-07-06 11:30:33 +0200
commit7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa (patch)
treed2efedef80b6b28a65139f1cd6d41aed380a6780 /target/linux
parent6b127d86390f85e92e59f3dba04fa585efb3b2c5 (diff)
downloadupstream-7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa.tar.gz
upstream-7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa.tar.bz2
upstream-7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa.zip
build: enable gzipping of images on x86 even if ext4 is disabled
There is lots of padding between the boot partition and the rootfs, so gzipping is helpful here Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index ca5d0123c7..d3005d79c3 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -153,11 +153,9 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
define Image/Build/gzip/ext4
$(call Image/Build/gzip,ext4)
endef
- ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
- define Image/Build/gzip/squashfs
+ define Image/Build/gzip/squashfs
$(call Image/Build/gzip,squashfs)
- endef
- endif
+ endef
endif
define Image/BuildKernel