aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-27 09:42:58 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-27 09:42:58 +0000
commit702fd5cdb5ed5899f6d9430ad75ee80803898ebe (patch)
tree5e24ac8fb26e155ef1d8ee1d9f8d42afdb95ae05 /target/linux
parent3a86affcdd3daa258c9d94578857da9c124a1574 (diff)
downloadupstream-702fd5cdb5ed5899f6d9430ad75ee80803898ebe.tar.gz
upstream-702fd5cdb5ed5899f6d9430ad75ee80803898ebe.tar.bz2
upstream-702fd5cdb5ed5899f6d9430ad75ee80803898ebe.zip
generate images for the D-Link DWL-3150 as well
SVN-Revision: 33961
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm47xx/image/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 33290ff35a..871175ed40 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -29,6 +29,11 @@ define Image/Build/wgt634u
cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/openwrt-wgt634u-$(2).bin
endef
+define Image/Build/dwl3150
+ cp $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-dwl3150-$(2).bin
+ echo "BCM-5352-2050-0000000-01" >> $(BIN_DIR)/openwrt-dwl3150-$(2).bin
+endef
+
define Image/Build/CyberTAN
$(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -o $(BIN_DIR)/openwrt-$(2)-$(5).bin $(if $(6),-s $(6))
endef
@@ -90,6 +95,7 @@ define Image/Build/jffs2-64k
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/dwl3150,$(1),$(patsubst jffs2-%,jffs2,$(1)))
endef
define Image/Build/squashfs