aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2018-04-29 19:07:05 +0300
committerJohn Crispin <john@phrozen.org>2018-05-05 06:57:00 +0200
commit6409b159e8b84e172da7755088d587ccd99103ab (patch)
treeb63ecbe74f57c42d40c852d3772c965bd465da6e /target/linux
parent20d0dace40b74b098309cefb29a1ce5d57988e7e (diff)
downloadupstream-6409b159e8b84e172da7755088d587ccd99103ab.tar.gz
upstream-6409b159e8b84e172da7755088d587ccd99103ab.tar.bz2
upstream-6409b159e8b84e172da7755088d587ccd99103ab.zip
gemini: switch to 4.14
This introduces Device/ infrastructure and images for all boards available upstream. Changes from Linus submitted version: - fix Raidsonic image generation - remove redundant (old) image generation - remove redundant header tool for dns313 board Signed-off-by: Linus Walleij <linus.walleij@linaro.org> Signed-off-by: Roman Yeryomin <roman@advem.lv>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/gemini/Makefile13
-rw-r--r--target/linux/gemini/base-files/lib/preinit/05_set_ether_mac_gemini25
-rw-r--r--target/linux/gemini/image/Makefile165
-rw-r--r--target/linux/gemini/raidsonic/config-default5
-rw-r--r--target/linux/gemini/raidsonic/target.mk17
-rw-r--r--target/linux/gemini/wiligear/target.mk10
6 files changed, 132 insertions, 103 deletions
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index f02e4b179f..a9414a2606 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=gemini
BOARDNAME:=Cortina Systems CS351x
-SUBTARGETS:=raidsonic wiligear
-FEATURES:=squashfs pci rtc
+FEATURES:=squashfs pci rtc usb dt gpio
CPU_TYPE:=fa526
MAINTAINER:=Roman Yeryomin <roman@advem.lv>
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
-KERNELNAME:=zImage
+define Target/Description
+ Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/gemini/base-files/lib/preinit/05_set_ether_mac_gemini b/target/linux/gemini/base-files/lib/preinit/05_set_ether_mac_gemini
index 499608120e..1ce5c8067e 100644
--- a/target/linux/gemini/base-files/lib/preinit/05_set_ether_mac_gemini
+++ b/target/linux/gemini/base-files/lib/preinit/05_set_ether_mac_gemini
@@ -1,13 +1,28 @@
#!/bin/sh
set_ether_mac() {
+ # Most devices have a standard "VCTL" partition
CONFIG_PARTITION="$(grep "VCTL" /proc/mtd | cut -d: -f1)"
- MAC1="$(strings /dev/$CONFIG_PARTITION |grep MAC|cut -d: -f2|cut -c3-14|sed -e 's,\(..\),:\1,g' -e 's,^:,,')"
- MAC2="$(strings /dev/$CONFIG_PARTITION |grep MAC|cut -d: -f8|cut -c3-14|sed -e 's,\(..\),:\1,g' -e 's,^:,,')"
+ if [ ! -z $CONFIG_PARTITION ] ; then
+ MAC1="$(strings /dev/$CONFIG_PARTITION |grep MAC|cut -d: -f2|cut -c3-14|sed -e 's,\(..\),:\1,g' -e 's,^:,,')"
+ MAC2="$(strings /dev/$CONFIG_PARTITION |grep MAC|cut -d: -f8|cut -c3-14|sed -e 's,\(..\),:\1,g' -e 's,^:,,')"
- ifconfig eth0 hw ether $MAC1 2>/dev/null
- ifconfig eth1 hw ether $MAC2 2>/dev/null
+ ifconfig eth0 hw ether $MAC1 2>/dev/null
+ ifconfig eth1 hw ether $MAC2 2>/dev/null
+ return 0
+ fi
+
+ # The DNS-313 has a special field in its RedBoot
+ # binary that we need to check
+ CONFIG_PARTITION="$(grep "RedBoot" /proc/mtd | cut -d: -f1)"
+ if [ ! -z $CONFIG_PARTITION ] ; then
+ DEVID="$(dd if=/dev/mtdblock0 bs=1 skip=119508 count=7 2>/dev/null)"
+ if [ "x$DEVID" = "xdns-313" ] ; then
+ MAC1="$(dd if=/dev/mtdblock0 bs=1 skip=119540 count=6 2>/dev/null | hexdump -n6 -e '/1 ":%02X"' | sed s/^://g)"
+ ifconfig eth0 hw ether $MAC1 2>/dev/null
+ return 0
+ fi
+ fi
}
boot_hook_add preinit_main set_ether_mac
-
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 2cea857770..908045a2de 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2014 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,81 +7,124 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-ifeq ($(SUBTARGET),wiligear)
-define Image/Prepare
-# WBD111: mach id 1690 (0x69a)
- echo -en "\x06\x1c\xa0\xe3\x9a\x10\x81\xe3" > $(KDIR)/wbd111-zImage
- cat $(KDIR)/zImage >> $(KDIR)/wbd111-zImage
-# WBD222: mach id 2753 (0xAC1)
- echo -en "\x0a\x1c\xa0\xe3\xc1\x10\x81\xe3" > $(KDIR)/wbd222-zImage
- cat $(KDIR)/zImage >> $(KDIR)/wbd222-zImage
+# Build the special D-Link DNS-313 header generator tool
+# needed to generate the hard disk boot images then
+# build D-Link DNS-313 images using the special header tool.
+# rootfs.tgz and rd.tgz contains nothing, we only need them
+# to satisfy the boot loader on the device. The zImage is
+# the only real content.
+define Build/dns313-images
+ if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
+ mkdir -p $(BIN_DIR)/.boot
+ echo "dummy" > $(BIN_DIR)/.boot/dummyfile
+ dns313-header $(BIN_DIR)/.boot/dummyfile \
+ $(BIN_DIR)/.boot/rootfs.tgz
+ dns313-header $(BIN_DIR)/.boot/dummyfile \
+ $(BIN_DIR)/.boot/rd.gz
+ dns313-header $(IMAGE_KERNEL) \
+ $(BIN_DIR)/.boot/zImage
+ rm -f $(BIN_DIR)/.boot/dummyfile
+ (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-dns313-bootpart.tar.gz .boot)
+ if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
endef
-endif
-ifeq ($(SUBTARGET),raidsonic)
-define Image/Prepare
-# NAS4220: mach id 2038 (0x7F6)
- echo -en "\x07\x1c\xa0\xe3\xf6\x10\x81\xe3" > $(KDIR)/nas4220-zImage
- cat $(KDIR)/zImage >> $(KDIR)/nas4220-zImage
+# Create the special NAS4220B image format with the squashfs
+# split across two "partitions" named rd.gz and hddapp.tgz but
+# essentially just being used by OpenWRT as one big partition
+define Build/nas4220b-images
+ dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
+ dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
+ cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
+ cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
+ (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220b.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
+ mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-rd.gz
+ mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-hddapp.tgz
+ mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-zImage
+ rm -f $(BIN_DIR)/ImageInfo
endef
-endif
-ifeq ($(SUBTARGET),wiligear)
-define Image/BuildKernel
-# workaround the bootloader's bug with extra nops
- echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/$(IMG_PREFIX)-wbd111-zImage
- cat $(KDIR)/wbd111-zImage >> $(BIN_DIR)/$(IMG_PREFIX)-wbd111-zImage
- echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/$(IMG_PREFIX)-wbd222-zImage
- cat $(KDIR)/wbd222-zImage >> $(BIN_DIR)/$(IMG_PREFIX)-wbd222-zImage
+# WBD-111 and WBD-222:
+# work around the bootloader's bug with extra nops
+# FIXME: is this really needed now that we no longer append the code
+# to change the machine ID number? Needs testing on Wiliboard.
+define Build/wbd-nops
+ mv $@ $@.tmp
+ echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $@
+ cat $@.tmp >> $@
+ rm -f $@.tmp
endef
-endif
-define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
+# All DTB files are prefixed with "gemini-"
+define Device/Default
+ DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+ KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
+ KERNEL_NAME := zImage
+ KERNEL := kernel-bin | append-dtb
+ FILESYSTEMS := squashfs
+ IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1).$$(2)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
endef
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
+# A reasonable set of default packages handling the NAS type
+# of devices out of the box (former NAS42x0 IcyBox defaults)
+GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
+ kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
+ kmod-fs-btrfs kmod-fs-cifs kmod-fs-ext4 kmod-fs-nfs \
+ kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
+ kmod-nls-utf8 kmod-usb-storage-extras \
+ samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
+
+DIR685_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda1 rw rootwait
+define Device/dlink-dir-685
+ DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+ CMDLINE := $(DIR685_CMDLINE)
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
endef
+TARGET_DEVICES += dlink-dir-685
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
+DNS313_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda4 rw rootwait
+define Device/dlink-dns-313
+ DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+ CMDLINE := $(DNS313_CMDLINE)
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+ IMAGES += dns313-image
+ IMAGE/dns313-image := dns313-images
endef
+TARGET_DEVICES += dlink-dns-313
-ifeq ($(SUBTARGET),wiligear)
-define Image/Build
- $(call Image/Build/$(1),$(1))
- -$(STAGING_DIR_HOST)/bin/mkfwimage2 \
- -m GEOS -f 0x30000000 -z \
- -v WILI-S.WILIBOARD.v5.00.SL3512.OpenWrt.00000.000000.000000 \
- -o $(BIN_DIR)/$(IMG_PREFIX)-wbd111-$(1).bin \
- -p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-wbd111-zImage \
- -p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+define Device/nas4220b
+ DEVICE_TITLE := Raidsonic NAS IB-4220-B
+ IMAGES += nas4220b-image
+ IMAGE/nas4220b-image := nas4220b-images
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+endef
+TARGET_DEVICES += nas4220b
- -$(STAGING_DIR_HOST)/bin/mkfwimage2 \
- -m GEOS -f 0x30000000 -z \
- -v WILI-S.WBD222.v5.00.SL3512.OpenWrt.00000.000000.000000 \
- -o $(BIN_DIR)/$(IMG_PREFIX)-wbd222-$(1).bin \
- -p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-wbd222-zImage \
- -p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+define Device/rut1xx
+ DEVICE_TITLE := Teltonika RUT1xx
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
endef
-endif
+TARGET_DEVICES += rut1xx
-ifeq ($(SUBTARGET),raidsonic)
-define Image/Build
- $(call Image/Build/$(1),$(1))
- dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img of=$(BIN_DIR)/rd.gz bs=6144k count=1
-# dd if=/dev/zero of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1
- dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
- cp $(KDIR)/nas4220-zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220-zImage
- cp $(BIN_DIR)/$(IMG_PREFIX)-nas4220-zImage $(BIN_DIR)/zImage
- cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
- (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
- mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220-rd.gz
- mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220-hddapp.tgz
- rm -f $(BIN_DIR)/zImage $(BIN_DIR)/ImageInfo
+SQ201_CMDLINE:=-console=ttyS0,115200n8
+define Device/sq201
+ DEVICE_TITLE := ITian Square One SQ201
+ CMDLINE := $(SQ201_CMDLINE)
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+endef
+TARGET_DEVICES += sq201
+
+define Device/wbd111
+ DEVICE_TITLE := Wiliboard WBD-111
+ KERNEL := kernel-bin | append-dtb | wbd-nops
+endef
+TARGET_DEVICES += wbd111
+
+define Device/wbd222
+ DEVICE_TITLE := Wiliboard WBD-222
+ KERNEL := kernel-bin | append-dtb | wbd-nops
endef
-endif
+TARGET_DEVICES += wbd222
$(eval $(call BuildImage))
diff --git a/target/linux/gemini/raidsonic/config-default b/target/linux/gemini/raidsonic/config-default
deleted file mode 100644
index 91605238b4..0000000000
--- a/target/linux/gemini/raidsonic/config-default
+++ /dev/null
@@ -1,5 +0,0 @@
-CONFIG_CMDLINE="rootfstype=squashfs,jffs2 noinitrd console=ttyS0,19200 mem=128M mtdparts=physmap-flash.0:128k(BOOT),3072k(Kern),6144k(Ramdisk),6144k(Application),128k(VCTL),640k(CurConf),128k(FIS-directory),12288k@0x320000(rootfs),15360k@0x20000(firmware) root=/dev/mtdblock7"
-CONFIG_MACH_NAS4220B=y
-CONFIG_MTD_CMDLINE_PARTS=y
-# CONFIG_MTD_REDBOOT_PARTS is not set
-CONFIG_MTD_SPLIT_FIRMWARE=y
diff --git a/target/linux/gemini/raidsonic/target.mk b/target/linux/gemini/raidsonic/target.mk
deleted file mode 100644
index d158090d4d..0000000000
--- a/target/linux/gemini/raidsonic/target.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-
-SUBTARGET:=raidsonic
-BOARDNAME:=Raidsonic NAS42x0
-FEATURES+=usb
-DEFAULT_PACKAGES+=kmod-usb2 kmod-md-mod kmod-md-linear kmod-md-multipath \
- kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
- kmod-fs-btrfs kmod-fs-cifs kmod-fs-ext4 kmod-fs-nfs \
- kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
- kmod-nls-utf8 kmod-usb-storage-extras \
- samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
-
-define Target/Description
- Build firmware images for Raidsonic NAS4220.
-endef
diff --git a/target/linux/gemini/wiligear/target.mk b/target/linux/gemini/wiligear/target.mk
deleted file mode 100644
index 97cab18590..0000000000
--- a/target/linux/gemini/wiligear/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-
-SUBTARGET:=wiligear
-BOARDNAME:=Wiligear WBD-222/111
-
-define Target/Description
- Build firmware images for Wiligear WBD-222 and WBD-111 boards.
-endef