aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:14 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:14 +0000
commit4ecae78c1605e48d35f130dbd62b7b3dcb9a0540 (patch)
tree73b56eac8433bed61e9f70a105672e421d004e82 /target/linux
parent79b733264b709bdc1e855fb019d6d195c737fab9 (diff)
downloadupstream-4ecae78c1605e48d35f130dbd62b7b3dcb9a0540.tar.gz
upstream-4ecae78c1605e48d35f130dbd62b7b3dcb9a0540.tar.bz2
upstream-4ecae78c1605e48d35f130dbd62b7b3dcb9a0540.zip
image.mk: replace all Build/netgear-chk with a generic implementation
Instead of letting each target define it themselves, create on in include/image.mk and let the targets use it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46596
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/bcm53xx/image/Makefile6
-rw-r--r--target/linux/brcm47xx/image/Makefile9
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile6
3 files changed, 0 insertions, 21 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fdb2c05e3a..7aa9fc2a3a 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -60,12 +60,6 @@ define Build/asus-trx
mv $@.new $@
endef
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg \
- -o $@.new -k $@ -b $(NETGEAR_BOARD_ID) -r $(NETGEAR_REGION)
- mv $@.new $@
-endef
-
DEVICE_VARS += DT PRODUCTID NETGEAR_BOARD_ID NETGEAR_REGION
define Device/Default
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index b2516a994c..7405d0f28d 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -126,15 +126,6 @@ define Build/linksys-bin
mv $@.new $@
endef
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg \
- -o $@.new \
- -k $@ \
- -b $(NETGEAR_BOARD_ID) \
- -r $(NETGEAR_REGION)
- mv $@.new $@
-endef
-
#################################################
# Devices
#################################################
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 235b60c404..c5c982f5e1 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -136,12 +136,6 @@ define Build/cfe-spw303v-bin
$(CFE_EXTRAS)
endef
-define Build/netgear-chk
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $@.netgear -k $@ \
- -b $(NETGEAR_BOARD_ID) -r $(NETGEAR_REGION)
- mv $@.netgear $@
-endef
-
define Build/spw303v-bin
$(STAGING_DIR_HOST)/bin/spw303v -i $@ -o $@.spw303v
mv $@.spw303v $@