aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-05-31 11:16:22 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-11 21:21:45 +0200
commit3a3cd0ac4376657eccfe30fc2fdcc91acddb8f1d (patch)
tree3eb564a03e3fa94d8e94e75167f0ea90b1290f8a /target/linux
parentaf27dd1a51d0aa093e36971eafef4cbc9e1e01c3 (diff)
downloadupstream-3a3cd0ac4376657eccfe30fc2fdcc91acddb8f1d.tar.gz
upstream-3a3cd0ac4376657eccfe30fc2fdcc91acddb8f1d.tar.bz2
upstream-3a3cd0ac4376657eccfe30fc2fdcc91acddb8f1d.zip
ar71xx: image: keep DEVICE_VARS and Build/* at the beginning
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/generic.mk81
-rw-r--r--target/linux/ar71xx/image/nand.mk33
-rw-r--r--target/linux/ar71xx/image/senao.mk1
-rw-r--r--target/linux/ar71xx/image/ubnt.mk5
4 files changed, 60 insertions, 60 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index cf1b7d10d7..949fadb07c 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -1,3 +1,44 @@
+DEVICE_VARS += DAP_SIGNATURE SEAMA_SIGNATURE
+
+define Build/mkbuffaloimg
+ $(STAGING_DIR_HOST)/bin/mkbuffaloimg -B $(BOARDNAME) \
+ -R $$(($(subst k, * 1024,$(ROOTFS_SIZE)))) \
+ -K $$(($(subst k, * 1024,$(KERNEL_SIZE)))) \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
+define Build/mkwrggimg
+ $(STAGING_DIR_HOST)/bin/mkwrggimg -b \
+ -i $@ -o $@.imghdr -d /dev/mtdblock/1 \
+ -m $(BOARDNAME) -s $(DAP_SIGNATURE) \
+ -v LEDE -B $(REVISION)
+ mv $@.imghdr $@
+endef
+
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ $(if $(1),$(1),-m "dev=/dev/mtdblock/1" -m "type=firmware")
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(call Build/seama,-s $@.seama $(1))
+endef
+
+define Build/uImageHiWiFi
+ # Field ih_name needs to start with "tw150v1"
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+ @mv $@.new $@
+endef
+
+define Build/wrgg-pad-rootfs
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS) -c 64 >>$@
+endef
+
+
define Device/ap531b0
DEVICE_TITLE := Rockeetech AP531B0
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
@@ -645,15 +686,6 @@ endef
TARGET_DEVICES += c-55
-define Build/uImageHiWiFi
- # Field ih_name needs to start with "tw150v1"
- mkimage -A $(LINUX_KARCH) \
- -O linux -T kernel \
- -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
- @mv $@.new $@
-endef
-
define Device/hiwifi-hc6361
DEVICE_TITLE := HiWiFi HC6361
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage \
@@ -668,15 +700,6 @@ endef
TARGET_DEVICES += hiwifi-hc6361
-define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ $(if $(1),$(1),-m "dev=/dev/mtdblock/1" -m "type=firmware")
- mv $@.seama $@
-endef
-
-define Build/seama-seal
- $(call Build/seama,-s $@.seama $(1))
-endef
-
define Device/seama
LOADER_TYPE := bin
BLOCKSIZE := 64k
@@ -697,7 +720,6 @@ define Device/seama
seama-seal -m "signature=$$$$(SEAMA_SIGNATURE)" | \
check-size $$$$(IMAGE_SIZE)
SEAMA_SIGNATURE :=
- DEVICE_VARS += SEAMA_SIGNATURE
endef
define Device/dir-869-a1
@@ -746,18 +768,6 @@ endef
TARGET_DEVICES += dir-869-a1 mynet-n600 mynet-n750 qihoo-c301
-define Build/mkwrggimg
- $(STAGING_DIR_HOST)/bin/mkwrggimg -b \
- -i $@ -o $@.imghdr -d /dev/mtdblock/1 \
- -m $(BOARDNAME) -s $(DAP_SIGNATURE) \
- -v LEDE -B $(REVISION)
- mv $@.imghdr $@
-endef
-
-define Build/wrgg-pad-rootfs
- $(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS) -c 64 >>$@
-endef
-
define Device/dap-2695-a1
DEVICE_TITLE := D-Link DAP-2695 rev. A1
DEVICE_PACKAGES := ath10k-firmware-qca988x kmod-ath10k
@@ -770,19 +780,10 @@ define Device/dap-2695-a1
KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
MTDPARTS = spi0.0:256k(bootloader)ro,64k(bdcfg)ro,64k(rgdb)ro,64k(langpack)ro,15360k(firmware),448k(captival)ro,64k(certificate)ro,64k(radiocfg)ro
DAP_SIGNATURE := wapac02_dkbs_dap2695
- DEVICE_VARS += DAP_SIGNATURE
endef
TARGET_DEVICES += dap-2695-a1
-define Build/mkbuffaloimg
- $(STAGING_DIR_HOST)/bin/mkbuffaloimg -B $(BOARDNAME) \
- -R $$(($(subst k, * 1024,$(ROOTFS_SIZE)))) \
- -K $$(($(subst k, * 1024,$(KERNEL_SIZE)))) \
- -i $@ -o $@.new
- mv $@.new $@
-endef
-
define Device/bhr-4grv2
DEVICE_TITLE := Buffalo BHR-4GRV2
BOARDNAME := BHR-4GRV2
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index 3b8ce617cd..05e043f542 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -1,3 +1,20 @@
+define Build/MerakiNAND
+ -$(STAGING_DIR_HOST)/bin/mkmerakifw \
+ -B $(BOARDNAME) -s \
+ -i $@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
+define Build/MerakiNAND-old
+ -$(STAGING_DIR_HOST)/bin/mkmerakifw-old \
+ -B $(BOARDNAME) -s \
+ -i $@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
+
define Device/c-60
DEVICE_TITLE := AirTight C-60
DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-core kmod-usb2 kmod-ath9k
@@ -41,14 +58,6 @@ define Device/hiveap-121
endef
TARGET_DEVICES += hiveap-121
-define Build/MerakiNAND
- -$(STAGING_DIR_HOST)/bin/mkmerakifw \
- -B $(BOARDNAME) -s \
- -i $@ \
- -o $@.new
- @mv $@.new $@
-endef
-
define Device/mr18
DEVICE_TITLE := Meraki MR18
DEVICE_PACKAGES := kmod-spi-gpio kmod-ath9k
@@ -62,14 +71,6 @@ define Device/mr18
endef
TARGET_DEVICES += mr18
-define Build/MerakiNAND-old
- -$(STAGING_DIR_HOST)/bin/mkmerakifw-old \
- -B $(BOARDNAME) -s \
- -i $@ \
- -o $@.new
- @mv $@.new $@
-endef
-
define Device/rambutan
DEVICE_TITLE := 8devices Rambutan
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
diff --git a/target/linux/ar71xx/image/senao.mk b/target/linux/ar71xx/image/senao.mk
index 50d3ccdfe1..46ea9703fa 100644
--- a/target/linux/ar71xx/image/senao.mk
+++ b/target/linux/ar71xx/image/senao.mk
@@ -12,6 +12,7 @@ define Build/senao-factory-image
rm -rf $@.senao
endef
+
define Device/ens202ext
DEVICE_TITLE := EnGenius ENS202EXT
BOARDNAME := ENS202EXT
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 2c7c35db8f..c5d30965ee 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -1,6 +1,4 @@
-# UBNT_BOARD e.g. one of (XS2, XS5, RS, XM)
-# UBNT_TYPE e.g. one of (BZ, XM, XW)
-# UBNT_CHIP e.g. one of (ar7240, ar933x, ar934x)
+DEVICE_VARS += UBNT_BOARD UBNT_CHIP UBNT_TYPE
# mkubntimage is using the kernel image direct
# routerboard creates partitions out of the ubnt header
@@ -34,7 +32,6 @@ define Build/mkubntimage2
@mv $@.new $@
endef
-DEVICE_VARS += UBNT_BOARD UBNT_CHIP UBNT_TYPE
# UBNT_BOARD e.g. one of (XS2, XS5, RS, XM)
# UBNT_TYPE e.g. one of (BZ, XM, XW)