aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-01-08 23:49:22 +0100
committerMathias Kresin <dev@kresin.me>2018-01-09 22:06:55 +0100
commit0674a99f7eb0c630b25eca774e3fe341d6c0efc8 (patch)
treee4531d269100322f0133d8119861bfc47e60efce /target/linux
parent0e94df65ca7f6a5c39421100c223c92889205b6f (diff)
downloadupstream-0674a99f7eb0c630b25eca774e3fe341d6c0efc8.tar.gz
upstream-0674a99f7eb0c630b25eca774e3fe341d6c0efc8.tar.bz2
upstream-0674a99f7eb0c630b25eca774e3fe341d6c0efc8.zip
kirkwood: sort occurrences of boardame alphabetically
This restores the alphabetical sort that was present before the renaming of boardname. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/kirkwood/base-files/etc/board.d/01_leds24
-rwxr-xr-xtarget/linux/kirkwood/base-files/etc/board.d/02_network19
-rwxr-xr-xtarget/linux/kirkwood/base-files/etc/diag.sh14
-rw-r--r--target/linux/kirkwood/image/Makefile118
4 files changed, 87 insertions, 88 deletions
diff --git a/target/linux/kirkwood/base-files/etc/board.d/01_leds b/target/linux/kirkwood/base-files/etc/board.d/01_leds
index b8a9b479e4..4e72e344aa 100755
--- a/target/linux/kirkwood/base-files/etc/board.d/01_leds
+++ b/target/linux/kirkwood/base-files/etc/board.d/01_leds
@@ -10,9 +10,9 @@ board_config_update
board=$(board_name)
case "$board" in
-"seagate,dockstar")
- ucidef_set_led_default "health" "health" "status:green:health" "1"
- ucidef_set_led_default "fault" "fault" "status:orange:fault" "1"
+"cloudengines,pogoe02")
+ ucidef_set_led_default "health" "health" "pogo_e02:green:health" "1"
+ ucidef_set_led_default "fault" "fault" "pogo_e02:orange:fault" "1"
;;
"linksys,audi")
ucidef_set_led_default "power" "power" "audi:green:power" "1"
@@ -21,18 +21,18 @@ case "$board" in
ucidef_set_led_default "health" "health" "viper:white:health" "1"
ucidef_set_led_default "pulse" "pulse" "viper:white:pulse" "1"
;;
-"seagate,goflexhome" | \
-"seagate,goflexnet")
- ucidef_set_led_default "health" "health" "status:green:health" "1"
- ucidef_set_led_default "fault" "fault" "status:orange:fault" "0"
- ;;
"raidsonic,ib-nas62x0")
ucidef_set_led_default "health" "health" "ib62x0:green:os" "1"
ucidef_set_led_default "fault" "fault" "ib62x0:red:os" "1"
;;
-"cloudengines,pogoe02")
- ucidef_set_led_default "health" "health" "pogo_e02:green:health" "1"
- ucidef_set_led_default "fault" "fault" "pogo_e02:orange:fault" "1"
+"seagate,dockstar")
+ ucidef_set_led_default "health" "health" "status:green:health" "1"
+ ucidef_set_led_default "fault" "fault" "status:orange:fault" "1"
+ ;;
+"seagate,goflexhome"|\
+"seagate,goflexnet")
+ ucidef_set_led_default "health" "health" "status:green:health" "1"
+ ucidef_set_led_default "fault" "fault" "status:orange:fault" "0"
;;
"zyxel,nsa310b")
ucidef_set_led_default "health" "health" "nsa310:green:sys" "1"
@@ -46,8 +46,6 @@ case "$board" in
ucidef_set_led_ataport "hdd1" "HDD1" "nsa325:green:sata1" "1"
ucidef_set_led_ataport "hdd2" "HDD2" "nsa325:green:sata2" "2"
;;
-*)
- ;;
esac
board_config_flush
diff --git a/target/linux/kirkwood/base-files/etc/board.d/02_network b/target/linux/kirkwood/base-files/etc/board.d/02_network
index 0b760fc165..5d66e0ffea 100755
--- a/target/linux/kirkwood/base-files/etc/board.d/02_network
+++ b/target/linux/kirkwood/base-files/etc/board.d/02_network
@@ -11,13 +11,16 @@ board_config_update
board=$(board_name)
case "$board" in
+"cisco,on100")
+ ucidef_set_interface_lan "eth0 eth1"
+ ;;
+"cloudengines,pogoe02"|\
+"cloudengines,pogoplugv4"|\
+"iom,iconnect-1.1"|\
+"raidsonic,ib-nas62x0"|\
"seagate,dockstar"|\
"seagate,goflexhome"|\
-"seagate,goflexnet"|\
-"raidsonic,ib-nas62x0"|\
-"iom,iconnect-1.1"|\
-"cloudengines,pogoe02"|\
-"cloudengines,pogoplugv4")
+"seagate,goflexnet")
ucidef_set_interface_lan "eth0" "dhcp"
;;
"linksys,audi"|\
@@ -25,13 +28,11 @@ case "$board" in
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "5@eth0" "6@eth1"
;;
-"zyxel,nsa310b"|"zyxel,nsa325")
+"zyxel,nsa310b"|\
+"zyxel,nsa325")
ucidef_set_interface_lan "eth0" "dhcp"
ucidef_set_interface_macaddr "lan" $( mtd_get_mac_ascii uboot_env ethaddr )
;;
-"cisco,on100")
- ucidef_set_interface_lan "eth0 eth1"
- ;;
*)
ucidef_set_interface_lan "eth0"
;;
diff --git a/target/linux/kirkwood/base-files/etc/diag.sh b/target/linux/kirkwood/base-files/etc/diag.sh
index ec9eead70d..0667ad29fe 100755
--- a/target/linux/kirkwood/base-files/etc/diag.sh
+++ b/target/linux/kirkwood/base-files/etc/diag.sh
@@ -6,10 +6,8 @@
get_status_led() {
case $(board_name) in
- seagate,dockstar|\
- seagate,goflexhome|\
- seagate,goflexnet)
- status_led="status:orange:fault"
+ cisco,on100)
+ status_led="on100:green:health"
;;
cloudengines,pogoe02)
status_led="pogo_e02:orange:fault"
@@ -23,12 +21,14 @@ get_status_led() {
linksys,viper)
status_led="viper:white:health"
;;
+ seagate,dockstar|\
+ seagate,goflexhome|\
+ seagate,goflexnet)
+ status_led="status:orange:fault"
+ ;;
zyxel,nsa310b)
status_led="nsa310:green:sys"
;;
- cisco,on100)
- status_led="on100:green:health"
- ;;
esac
}
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index f04c0323fb..39d93275f4 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -27,29 +27,40 @@ define Device/Default
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
endef
-define Device/seagate_dockstar
- DEVICE_DTS := kirkwood-dockstar
- DEVICE_TITLE := Seagate FreeAgent Dockstar
- BOARD_NAME := dockstar
- SUPPORTED_DEVICES += dockstar
+define Device/cisco_on100
+ DEVICE_TITLE := Cisco Systems ON100
+ DEVICE_DTS := kirkwood-on100
+ DEVICE_PACKAGES := kmod-i2c-mv64xxx
+ KERNEL_SIZE := 5376k
+ KERNEL_IN_UBI := 0
+ UBINIZE_OPTS := -E 5
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ BOARD_NAME := on100
endef
-TARGET_DEVICES += seagate_dockstar
+TARGET_DEVICES += cisco_on100
-define Device/seagate_goflexnet
- DEVICE_TITLE := Seagate GoFlexNet
- DEVICE_DTS := kirkwood-goflexnet
- BOARD_NAME := goflexnet
- SUPPORTED_DEVICES += goflexnet
+define Device/cloudengines_pogoe02
+ DEVICE_TITLE := Cloud Engines Pogoplug E02
+ DEVICE_DTS := kirkwood-pogo_e02
+ BOARD_NAME := pogo_e02
+ SUPPORTED_DEVICES += pogo_e02
endef
-TARGET_DEVICES += seagate_goflexnet
+TARGET_DEVICES += cloudengines_pogoe02
-define Device/seagate_goflexhome
- DEVICE_TITLE := Seagate GoFlexHome
- DEVICE_DTS := kirkwood-goflexhome
- BOARD_NAME := goflexhome
- SUPPORTED_DEVICES += goflexhome
+define Device/cloudengines_pogoplugv4
+ DEVICE_TITLE := Cloud Engines Pogoplug V4
+ DEVICE_DTS := kirkwood-pogoplug-series-4
+ DEVICE_PACKAGES := kmod-usb3
endef
-TARGET_DEVICES += seagate_goflexhome
+TARGET_DEVICES += cloudengines_pogoplugv4
+
+define Device/iom_iconnect-1.1
+ DEVICE_TITLE := Iomega Iconnect
+ DEVICE_DTS := kirkwood-iconnect
+ BOARD_NAME := iconnect
+ SUPPORTED_DEVICES += iconnect
+endef
+TARGET_DEVICES += iom_iconnect-1.1
define Device/linksys_audi
DEVICE_TITLE := Linksys EA3500 (Audi)
@@ -77,13 +88,37 @@ define Device/linksys_viper
endef
TARGET_DEVICES += linksys_viper
-define Device/iom_iconnect-1.1
- DEVICE_TITLE := Iomega Iconnect
- DEVICE_DTS := kirkwood-iconnect
- BOARD_NAME := iconnect
- SUPPORTED_DEVICES += iconnect
+define Device/raidsonic_ib-nas62x0
+ DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
+ DEVICE_DTS := kirkwood-ib62x0
+ BOARD_NAME := ib62x0
+ SUPPORTED_DEVICES += ib62x0
endef
-TARGET_DEVICES += iom_iconnect-1.1
+TARGET_DEVICES += raidsonic_ib-nas62x0
+
+define Device/seagate_dockstar
+ DEVICE_DTS := kirkwood-dockstar
+ DEVICE_TITLE := Seagate FreeAgent Dockstar
+ BOARD_NAME := dockstar
+ SUPPORTED_DEVICES += dockstar
+endef
+TARGET_DEVICES += seagate_dockstar
+
+define Device/seagate_goflexnet
+ DEVICE_TITLE := Seagate GoFlexNet
+ DEVICE_DTS := kirkwood-goflexnet
+ BOARD_NAME := goflexnet
+ SUPPORTED_DEVICES += goflexnet
+endef
+TARGET_DEVICES += seagate_goflexnet
+
+define Device/seagate_goflexhome
+ DEVICE_TITLE := Seagate GoFlexHome
+ DEVICE_DTS := kirkwood-goflexhome
+ BOARD_NAME := goflexhome
+ SUPPORTED_DEVICES += goflexhome
+endef
+TARGET_DEVICES += seagate_goflexhome
define Device/zyxel_nsa310b
DEVICE_TITLE := ZyXEL NSA310b
@@ -101,39 +136,4 @@ define Device/zyxel_nsa325
endef
TARGET_DEVICES += zyxel_nsa325
-define Device/cisco_on100
- DEVICE_TITLE := Cisco Systems ON100
- DEVICE_DTS := kirkwood-on100
- DEVICE_PACKAGES := kmod-i2c-mv64xxx
- KERNEL_SIZE := 5376k
- KERNEL_IN_UBI := 0
- UBINIZE_OPTS := -E 5
- IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
- BOARD_NAME := on100
-endef
-TARGET_DEVICES += cisco_on100
-
-define Device/cloudengines_pogoe02
- DEVICE_TITLE := Cloud Engines Pogoplug E02
- DEVICE_DTS := kirkwood-pogo_e02
- BOARD_NAME := pogo_e02
- SUPPORTED_DEVICES += pogo_e02
-endef
-TARGET_DEVICES += cloudengines_pogoe02
-
-define Device/cloudengines_pogoplugv4
- DEVICE_TITLE := Cloud Engines Pogoplug V4
- DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-usb3
-endef
-TARGET_DEVICES += cloudengines_pogoplugv4
-
-define Device/raidsonic_ib-nas62x0
- DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
- DEVICE_DTS := kirkwood-ib62x0
- BOARD_NAME := ib62x0
- SUPPORTED_DEVICES += ib62x0
-endef
-TARGET_DEVICES += raidsonic_ib-nas62x0
-
$(eval $(call BuildImage))